Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
代码:
#include<stdio.h>
int fib[1000010];
void f()
{
int i;
fib[0]=7;fib[1]=11;
for(i=2;i<1000010;++i)
fib[i]=(fib[i-1]+fib[i-2])%3; // !!!!之前没对3取余数,一直提交错误
}
int main()
{
f();
int n;
while(~scanf("%d",&n))
{
if(fib[n]%3==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}