poj3259Wormholes【最短路SPFA判断负环】

Wormholes

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 56   Accepted Submission(s) : 24
Problem Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

 

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
 

Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
 

Sample Input
  
  
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
 

Sample Output
  
  
NO YES
 
题目大意:利用虫洞的时光旅行,若能回到过去,则输出"YES",否则"NO"。
给定F(1<=F<=5)组数据,对应与一个farm,每组数据对应一个结果。 
对于其中一组数据,给定 N , M , W ,N为点数,M为无向边数(普通路径,通过之后时间前进),W为有向边数(虫洞,通过虫洞之后时间倒退),求每组数据是否存在一条回路能使时间倒退。 
解题思路:若存在这样一条回路,则图中肯定存在负环。只要判断是否有负环就行了。
【代码】
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int head[1000010],cnt;

struct Edge
{
	int u,v,w,next;
}edge[1000010];
int n,m,flag;
void add(int u,int v,int w)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].w=w;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
int vis[550];
int dist[550];
int used[550];
void SPFA(int s)
{
	flag=0;
	queue<int>q;
	memset(dist,INF,sizeof(dist));
	memset(vis,0,sizeof(vis));
	memset(used,0,sizeof(used));
	q.push(s);
	dist[s]=0;
	vis[s]=1;
	used[s]++;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].v;
			if(dist[v]>dist[u]+edge[i].w)
			{
				dist[v]=dist[u]+edge[i].w;
				if(!vis[v])
				{
					vis[v]=1;
					q.push(v);
					used[v]++;
					if(used[v]>n)
					{
						flag=1;
					    return;
					}
				}
			}
		}
	}
}
int main()
{
	int f,w,s,e,t;
	scanf("%d",&f);
	while(f--)
	{
		cnt=0;
		memset(head,-1,sizeof(head));
		scanf("%d%d%d",&n,&m,&w);
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&s,&e,&t);
			add(s,e,t);
			add(e,s,t);
		}
		for(int i=1;i<=w;i++)
		{
			scanf("%d%d%d",&s,&e,&t);
			add(s,e,-t);
		}
		SPFA(s);
		if(flag==0)
		    printf("NO\n");
		else
		    printf("YES\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值