N - Trailing Zeroes (III)
You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*…*N. For example, 5! = 120, 120 contains one zero on the trail.
Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.
Output
For each case, print the case number and N. If no solution is found then print ‘impossible’.
Sample Input
3
1
2
5
Sample Output
Case 1: 5
Case 2: 10
Case 3: impossible
思路:
一开始自己想找阶乘末尾0的个数的规律,打表。但是发现数据有1e8大。太大。
参考了别人的,其实是一个二分查找求下界的题。
l=0,r=100000000*5+10;
每次取中间值求其末尾0的个数。
当然最后得判断这个下界的末尾0的个数是不是等于输入的值。
代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
/*二分查找求下界+求阶乘末尾0*/
int solve(int n)
{
int num=0;
while(n)
{
num+=n/5;
n/=5;
}
return num;
}
int main()
{
int T;
scanf("%d",&T);
int tmp;
int ks=1;
while(T--)
{
scanf("%d",&tmp);
int l=0,r=100000000*5+10;
int mid;
int ans;
while(r>l)
{
mid =(r+l)>>1;
if(solve(mid)>=tmp)
{
ans=mid;
r=mid;
}
else
{
l=mid+1;
}
}
printf("Case %d: ",ks++);
if(solve(ans)==tmp)
{
cout<<ans<<endl;
}
else
{
printf("impossible\n");
}
}
return 0;
}