Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)
…
an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
题意:
给定一个序列,每次可以把第一个数移动到尾部再形成一个序列,求这些序列逆序数的最小值。
题解:
先用归并排序求出原始序列逆序数。我们通过找规律可以发现
1 3 6 9 0 8 5 7 4 2 逆序数为22
3 6 9 0 8 5 7 4 2 1 逆序数为22-1+10-1-1=29
6 9 0 8 5 7 4 2 1 3 逆序数为29-3+10-1-3=32
所以可得下一个序列的逆序数为上一个序列的逆序数加上-num+n-1-num
代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 5e3+10;
typedef long long LL;
LL cnt;
void merge_sort(LL A[],int x,int y,LL T[])
{
if(y-x>1)
{
int m = x+(y-x)/2; //划分
int p=x,q=m,i=x;
merge_sort(A,x,m,T);
merge_sort(A,m,y,T);
while(p<m||q<y)
{
if(q>=y||(p<m&&A[p]<=A[q]))
T[i++]=A[p++];
else
{T[i++]=A[q++];cnt+=m-p;}
}
for(i=x;i<y;i++) A[i]=T[i];
}
}
int main()
{
LL A[maxn];
LL T[maxn];
LL C[maxn];
int n;
while(cin>>n)
{
cnt=0;
memset(A,0,sizeof(A));
memset(T,0,sizeof(T));
memset(C,0,sizeof(C));
for(int i=0;i<n;i++)
{cin>>A[i];C[i]=A[i];}
merge_sort(A,0,n,T);
LL tmp=1<<30;
for(int i=0;i<n;i++)
{
cnt=cnt-(C[i]-0)+(n-C[i]-1);
tmp=min(cnt,tmp);
}
cout<<tmp<<endl;
}
return 0;
}