POJ1305 勾股数组

Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level. 
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2. 
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples). 
Input
The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file
Output
For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not part of any triple whose components are all <=N. There should be one output line for each input line.
Sample Input
10
25
100
Sample Output
1 4
4 9
16 27



题意:

1.找出勾股数a,b,c的个数,其中gcd(a,b,c)=1,a,b,c不超过n;  2. 和不能构成勾股数的数字。

解题:

设 a*a +b*b = c*c,并且gcd(a,b,c)=1;
把a,b奇偶讨论,可以得到a,b只能一奇一偶,把偶数的b 移到等式另外一边
可以得到 a*a=c*c-b*b ;即a*a = (c+b)(c-b);
假设d是c+b和c-b的公因数。则d也整除c+b+c-b=2c 和 c+b-(c-b)=2b (提取公因数有d),但是b,c没有公因数,所以 d只能为1或者2
但是d也整除a*a = (c+b)(c-b);又a是奇数,所以d为1;
又 (c+b)(c-b)是完全平方数,所以(c+b) 和 (c-b)也是完全平方数
则 可以设c+b = s*s c-b=t*t;
所以可得
 a = s*t
 b = (s*s-t*t)/2;
 c = (s*s+t*t)/2;
上面得到的就是 勾股数组定理


#include<stdio.h> 
#include<algorithm>
#include<string.h>
using namespace std;
// a = s*t
// b = (s*s-t*t)/2;
// c = (s*s+t*t)/2;
int gcd(int a,int b){
	return b==0?a:gcd(b,a%b);
}
int vis[1000005];
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int cnt=0;
		int ans=0;

		memset(vis,0,sizeof(vis));
		for(int s=1;s*s<2*n;s+=2){
			for(int t=1;s*t<=n&&s*s+t*t<=2*n;t+=2){
				if(gcd(s,t)!=1) continue;
				int a = s*t;
 				int b = (s*s-t*t)/2;
 				int c = (s*s+t*t)/2;
 				if((s*s-t*t)%2) continue;
 				if((s*s+t*t)%2) continue;
 				if(a<=0||b<=0||c<=0) continue;
 				if(a>n||b>n||c>n) continue;
 				for(int i=1;i<=n/max(max(a,b),c);i++)
 					vis[a*i]=vis[b*i]=vis[c*i]=1;
 				cnt++;
			}
		}
		for(int i=1;i<=n;i++){
			if(!vis[i]) ans++;
		}
		printf("%d %d\n",cnt,ans);
	}
}


另外补充一个勾股数组定理:

圆x*x+y*y=1上的坐标的有理数点,可以由公式((1-m*m)/(1+m*m),(2*m)/(1+m*m) )

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值