/*
奇怪的电梯(normal)
Time Limit:1000MS Memory Limit:65536K
Total Submit:200 Accepted:63
Description
呵呵,有一天我做了一个梦,梦见了一种很奇怪的电梯。大楼的每一层楼都可以停电梯,而且第i层楼(1<=i<=N)上有一个数字Ki(0<=Ki<=N)。电梯只有四个按钮:开,关,上,下。上下的层数等于当前楼层上的那个数字。当然,如果不能满足要求,相应的按钮就会失灵。例如:3 3 1 2 5代表了Ki(K1=3,K2=3,……),从一楼开始。在一楼,按“上”可以到4楼,按“下”是不起作用的,因为没有-2楼。那么,从A楼到B楼至少要按几次按钮呢?
Input
输入文件共有二行,第一行为三个用空格隔开的正整数,表示N,A,B(1≤N≤200, 1≤A,B≤N),第二行为N个用空格隔开的正整数,表示Ki。
Output
输出文件仅一行,即最少按键次数,若无法到达,则输出-1。
Sample Input
5 1 5
3 3 1 2 5
Sample Output
3
*/
#include < stdio.h >
#define MAX 501
int a,b,n ;
int v[MAX],flag = 0 ;
void trytofind( int x, int total)
{
if (x - v[x] == b || x + v[x] == b)
{
if ( total < flag || flag == 0 )
flag = total ;
}
else
{
if (x + v[x] <= n)
trytofind(x + v[x],total + 1 );
if (x - v[x] >= 1 )
trytofind(x - v[x],total + 1 );
}
}
int main( void )
{
int i,j,k ;
scanf( " %d %d %d " , & n, & a, & b);
for (i = 1 ; i <= n; i ++ )
scanf( " %d " , & v[i]);
trytofind(a, 1 ) ;
if (flag)
printf( " %d " ,flag);
else
printf( " -1 " );
system( " pause " );
return 0 ;
}
奇怪的电梯(normal)
Time Limit:1000MS Memory Limit:65536K
Total Submit:200 Accepted:63
Description
呵呵,有一天我做了一个梦,梦见了一种很奇怪的电梯。大楼的每一层楼都可以停电梯,而且第i层楼(1<=i<=N)上有一个数字Ki(0<=Ki<=N)。电梯只有四个按钮:开,关,上,下。上下的层数等于当前楼层上的那个数字。当然,如果不能满足要求,相应的按钮就会失灵。例如:3 3 1 2 5代表了Ki(K1=3,K2=3,……),从一楼开始。在一楼,按“上”可以到4楼,按“下”是不起作用的,因为没有-2楼。那么,从A楼到B楼至少要按几次按钮呢?
Input
输入文件共有二行,第一行为三个用空格隔开的正整数,表示N,A,B(1≤N≤200, 1≤A,B≤N),第二行为N个用空格隔开的正整数,表示Ki。
Output
输出文件仅一行,即最少按键次数,若无法到达,则输出-1。
Sample Input
5 1 5
3 3 1 2 5
Sample Output
3
*/
#include < stdio.h >
#define MAX 501
int a,b,n ;
int v[MAX],flag = 0 ;
void trytofind( int x, int total)
{
if (x - v[x] == b || x + v[x] == b)
{
if ( total < flag || flag == 0 )
flag = total ;
}
else
{
if (x + v[x] <= n)
trytofind(x + v[x],total + 1 );
if (x - v[x] >= 1 )
trytofind(x - v[x],total + 1 );
}
}
int main( void )
{
int i,j,k ;
scanf( " %d %d %d " , & n, & a, & b);
for (i = 1 ; i <= n; i ++ )
scanf( " %d " , & v[i]);
trytofind(a, 1 ) ;
if (flag)
printf( " %d " ,flag);
else
printf( " -1 " );
system( " pause " );
return 0 ;
}