FZU 1046 Tempter of the Bone

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO

YES

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int n,m,t;
int si,sj,di,dj;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
char map[9][9];
int flag;
void dfs(int si,int sj,int time)
{
	if(si>n||si<1||sj>m||sj<1)return;
	if(time==t&&si==di&&sj==dj)flag=1;
	if(flag)return ;
	if(((si+sj)%2==(di+dj)%2)&&((t-time)%2==1))return;
	if(((si+sj)%2!=(di+dj)%2)&&((t-time)%2==0))return;
	for(int i=0;i<4;i++)
	{
		if(map[si+dir[i][0]][sj+dir[i][1]]!='X')
		{
			map[si+dir[i][0]][sj+dir[i][1]]='X';
			dfs(si+dir[i][0],sj+dir[i][1],time+1);
			map[si+dir[i][0]][sj+dir[i][1]]='.';
		}
	}
	return;
}
int main()
{
	while(cin>>n>>m>>t)
	{
		if(n==0&&m==0&&t==0)break;
		int wall=0;//判断墙的数目;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='S')
				{
					si=i;
					sj=j;
				}
				if(map[i][j]=='D')
				{
					di=i;
					dj=j;
				}
				if(map[i][j]=='X')wall++;
			}
		}
			map[si][sj]='X';
			flag=0;
			dfs(si,sj,0);
			if(flag)
			cout<<"YES"<<endl; 
             else 
	        cout<<"NO"<<endl; 
		} 
		return 0;
}


内容概要:本文档详细介绍了如何在MATLAB环境下实现CNN-GRU(卷积门控循环单元)混合模型的多输入单输出回归预测。项目旨在通过融合CNN的局部特征提取能力和GRU的时序依赖捕捉能力,解决传统序列模型在处理非线性、高维、多输入特征数据时的局限性。文档涵盖了项目背景、目标、挑战及其解决方案,强调了模型的轻量化、高效性和可视化全流程追踪等特点。此外,还提供了具体的应用领域,如智能电网负荷预测、金融时间序列建模等,并附有详细的代码示例,包括数据加载与预处理、网络结构定义、训练选项设置、模型训练与预测以及结果可视化等步骤。; 适合人群:对深度学习有一定了解,特别是对时间序列预测感兴趣的科研人员或工程师。; 使用场景及目标:①需要处理多输入单输出的非线性回归预测任务;②希望在MATLAB平台上快速实现并优化深度学习模型;③寻求一种高效、轻量且具有良好泛化能力的预测模型应用于实际场景中,如智能电网、金融分析、交通流量预测等领域。; 阅读建议:由于文档内容涉及较多的技术细节和代码实现,建议读者先熟悉CNN和GRU的基本概念,同时掌握MATLAB的基础操作。在阅读过程中,可以结合提供的代码示例进行实践操作,以便更好地理解和掌握CNN-GRU混合模型的构建与应用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值