hdu5606 tree 并查集

本文介绍了一种基于树形结构的算法问题,探讨了如何通过遍历和连接权重为0的节点来确定每个节点所属联通块的个数,并最终计算这些个数的异或值。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

There is a tree(the tree is a connected graph which contains n points and n1 edges),the points are labeled from 1 to n ,which edge has a weight from 0 to 1,for every point i[1,n] ,you should find the number of the points which are closest to it,the clostest points can contain i

itself.
Input
the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer n ,means the number of the points,next n-1 lines,each line contains three numbers u,v,w ,which shows an edge and its weight.

T50,n105,u,v[1,n],w[0,1]

Output
for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i ,you only need to output, ans1 xor ans2 xor ans3.. ansn
.

Sample Input
1
3
1 2 0
2 3 1
 

 

Sample Output
1in the sample.$ans_1=2$$ans_2=2$$ans_3=1$$2~xor~2~xor~1=1$,so you need to output 1.

题面:给你一些点,求各个点联通块的个数的异或值。 遇到1则断,0是联通。

比较容易,0就unit,1就不管好了,最后输出的时候整理一下fa[i]的值 如果是偶数就跳过,因为偶数次异或是0,遇到奇数则操作。

比如sample中其实不需要算2^2,只需要算1就好,同理如果有2个2,3个1的话,只需要考虑1,而不需要考虑1^1^1。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <cctype>
#include <ctime>
#include <map>
#include <set>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int dx[] = {-1, 0, 1, 0, -1, -1, 1, 1};
const int dy[] = {0, 1, 0, -1, 1, -1, 1, -1};
#define N 100050
#define eps 1e-5
#define pai acos(-1)
#define MOD 1e9+7
int fa[N],a[N];
void init()
{
    for(int i=1;i<=100005;i++)
    {
        fa[i]=i;
        a[i]=0;
    }
}
int findd(int x)
{
    if(x==fa[x]) return x;
    else return fa[x]=findd(fa[x]);
}
void unite(int x,int y)
{
    x=findd(x),y=findd(y);
    if(x==y) return ;
    else fa[x]=y;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    ll _begin=clock();
    #endif
    int n,m;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        init();
        scanf("%d",&m);
        int mm=m;
        while(--m)
        {
            int from,to,w;
            scanf("%d%d%d",&from,&to,&w);
            if(!w)
            {
                unite(from,to);
            }
        }
        m=mm;
        for(int i=1;i<=m;i++) fa[i]=findd(i);
        int ans=0;
        for(int i=1;i<=m;i++)
        {
            a[fa[i]]++;
        }
        for(int i=1;i<=100000;i++)
        {
            if(a[i]%2==0) continue;
            ans=ans^a[i];
        }
        printf("%d\n",ans);
    }
    #ifndef ONLINE_JUDGE
    ll _end=clock();
    printf("%lldms\n",_end-_begin);
    #endif

    return 0;
}



### HDU 3342 并查集 解题思路与实现 #### 题目背景介绍 HDU 3342 是一道涉及并查集的数据结构题目。该类问题通常用于处理动态连通性查询,即判断若干元素是否属于同一集合,并支持高效的合并操作。 #### 数据描述 给定一系列的人际关系网络中的朋友关系对 (A, B),表示 A 和 B 是直接的朋友。目标是通过这些已知的关系推断出所有人之间的间接友谊连接情况。具体来说,如果存在一条路径使得两个人可以通过中间人的链条相连,则认为他们是间接朋友。 #### 思路分析 为了高效解决此类问题,可以采用带按秩压缩启发式的加权快速联合-查找算法(Weighted Quick Union with Path Compression)。这种方法不仅能够有效地管理大规模数据集下的分组信息,而且可以在几乎常数时间内完成每次查找和联合操作[^1]。 当遇到一个新的友链 `(a,b)` 时: - 如果 a 和 b 已经在同一棵树下,则无需任何动作; - 否则,执行一次 `union` 操作来把它们所在的两棵不同的树合并成一棵更大的树; 最终目的是统计有多少个独立的“朋友圈”,也就是森林里的树木数量减一即是所需新建桥梁的数量[^4]。 #### 实现细节 以下是 Python 版本的具体实现方式: ```python class DisjointSet: def __init__(self, n): self.parent = list(range(n)) self.rank = [0] * n def find(self, p): if self.parent[p] != p: self.parent[p] = self.find(self.parent[p]) # 路径压缩 return self.parent[p] def union(self, p, q): rootP = self.find(p) rootQ = self.find(q) if rootP == rootQ: return # 按秩合并 if self.rank[rootP] > self.rank[rootQ]: self.parent[rootQ] = rootP elif self.rank[rootP] < self.rank[rootQ]: self.parent[rootP] = rootQ else: self.parent[rootQ] = rootP self.rank[rootP] += 1 def solve(): N, M = map(int, input().split()) dsu = DisjointSet(N+1) # 初始化不相交集 for _ in range(M): u, v = map(int, input().split()) dsu.union(u,v) groups = set() for i in range(1,N+1): groups.add(dsu.find(i)) bridges_needed = len(groups)-1 print(f"Bridges needed to connect all components: {bridges_needed}") solve() ``` 这段代码定义了一个名为 `DisjointSet` 的类来进行并查集的操作,包括初始化、寻找根节点以及联合两个子集的功能。最后,在主函数 `solve()` 中读取输入参数并对每一对好友调用 `dsu.union()` 方法直到遍历完所有的边为止。之后计算不同组件的数量从而得出所需的桥接次数。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值