1066. Root of AVL Tree

本文介绍如何通过给定的一系列整数构建AVL树,并输出该树的根结点值。文章提供了完整的代码实现,包括结点定义、插入操作、旋转调整等关键步骤。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

imageimage

imageimage

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

题意

给定n个整数,要求建立AVL树,并输出根结点的值。

思路

正常操作构建AVL树即可。具体原理可以参考教材或百度。


代码实现

#include <cstdio>
#include <algorithm>
using namespace std;

/* 定义结点 */
struct node
{
    int data, height;
    node *lchild, *rchild;
};

/* 新建结点 */
node* newNode(int x)
{
    node* root = new node;
    root->data = x;
    root->height = 1;
    root->lchild = root->rchild = NULL;
    return root;
}

/* 获取结点高度 */
int getHeight(node* root)
{
    if (root == NULL)
        return 0;
    return root->height;
}

/* 获取平衡因子 */
int getBalanceFactor(node *root)
{
    return getHeight(root->lchild) - getHeight(root->rchild);
}

/* 更新结点高度 */
void updateHeight(node* root)
{
    root->height = max(getHeight(root->lchild), getHeight(root->rchild)) + 1;   // 根结点高度为子结点最大高度+1
}

/* 左旋 */
void L(node* &root)
{
    node* temp = root->rchild;
    root->rchild = temp->lchild;
    temp->lchild = root;
    updateHeight(root);
    updateHeight(temp);
    root = temp;
}

/* 右旋 */
void R(node* &root)
{
    node* temp = root->lchild;
    root->lchild = temp->rchild;
    temp->rchild = root;
    updateHeight(root);
    updateHeight(temp);
    root = temp;
}

/* 插入结点 */
void insertNode(node* &root, int x)
{
    if (root == NULL)       // 找到出入位置
    {
        root = newNode(x);
        return;
    }

    if (x < root->data)     // 向左子树插入
    {
        insertNode(root->lchild, x);
        updateHeight(root);
        if (getBalanceFactor(root) == 2)
            if (getBalanceFactor(root->lchild) == 1)    // LL情况
                R(root);
            else if (getBalanceFactor(root->lchild) == -1)  // LR情况
            {
                L(root->lchild);
                R(root);
            }
    }
    else        // 向右子树插入
    {
        insertNode(root->rchild, x);
        updateHeight(root);
        if (getBalanceFactor(root) == -2)
            if (getBalanceFactor(root->rchild) == -1)   // RR情况
                L(root);
            else if (getBalanceFactor(root->rchild) == 1)   // RL情况
            {
                R(root->rchild);
                L(root);
            }
    }
}

/* 创建AVL树 */
node* createAVL(int data[], int n)
{
    node* root = NULL;
    for (int i = 0; i < n; i++)
        insertNode(root, data[i]);
    return root;
}

int main()
{
    int data[21], n;

    scanf("%d", &n);
    for (int i = 0; i < n; i++)
        scanf("%d", &data[i]);

    node* root = createAVL(data, n);
    printf("%d", root->data);

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值