Count PAT’s
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.
Now given any string, you are supposed to tell the number of PAT’s contained in the string.
Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.
Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT
Sample Output:
2
题意
给定一串只包含’P’、‘A’、‘T’的字符串,只要在字符串中三种字符能够满足’P’、‘A’、'T’的排列顺序,就说可以组成一个"PAT",求出字符串中能够组成的"PAT"的总数。
思路
对于字符’A’来说,以它为中心的"PAT"的个数 = 该’A’前’P’的个数 * 该’A’后’T’的个数,因此可以按照以下步骤进行处理:先从头至尾遍历字符串,用一个数组p记录当前位置之前(包括该位置)‘P’的个数,令p[i] = p[i - 1],若当前位置i处字符为’P’,则p[i]++;再从尾至首遍历字符串,用countT来记录’T’的个数,如果当前字符为’T’,则countT++,若为’A’,则以该’A’为中心的"PAT"个数为p[i] * countT,将计算结果累加入总技术中,直到遍历完字符串,得到的就是组成的"PAT"的个数。
代码实现
#include <iostream>
#include <string>
#include <vector>
using namespace std;
vector<int> p; // 记录截止i位置处一共出现的'P'的个数
int solve(string s)
{
int ans = 0;
int countT = 0;
p.push_back(0);
if (s[0] == 'P')
p[0]++;
for (int i = 1; i < s.length(); i++) // 生成数组p
{
p.push_back(p[i - 1]);
if (s[i] == 'P')
p[i]++;
}
for (int i = s.length() - 1; i >= 0; i--)
{
if (s[i] == 'T')
countT++;
else if (s[i] == 'A') // 计算以该'A'为中心的"PAT"个数
ans = (ans + p[i] * countT % 1000000007) % 1000000007; // 累加结果,不要忘了取余
}
return ans;
}
int main()
{
string s;
int numPAT;
cin >> s;
numPAT = solve(s);
cout << numPAT;
return 0;
}