Java实验——排列

C语言实验——排列

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
有4个互不相同的数字,请按序输出由其中三个不重复数字组成的排列。
Input
4个整数。
Output
所有排列,输出顺序见样例。
Sample Input
1 2 3 4
Sample Output
1 2 3
1 3 2
2 1 3
2 3 1
3 1 2
3 2 1
1 2 4
1 4 2
2 1 4
2 4 1
4 1 2
4 2 1
1 3 4
1 4 3
3 1 4
3 4 1
4 1 3
4 3 1
2 3 4
2 4 3
3 2 4
3 4 2
4 2 3
4 3 2
Hint
 
Source
ZJGSU 

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);	
	    int i;
	    int a, b, c, d;
	    a = input.nextInt();
	    b = input.nextInt();
	    c = input.nextInt();
	    d = input.nextInt();
	    f(a, b,c);
	    f(a, b,d);
	    f(a, c, d);
	    f(b, c, d);
	}
	public static void f(int a, int b, int c) {
		int i, j, k;
		int d[] = new int[4];
		d[1] = a;
		d[2] = b;
		d[3] = c;
		for(i = 1; i <= 3; i++) {
			for(j = 1; j <= 3; j++) {
				for(k = 1; k <= 3; k++) {
					if(k != i && i != j && j != k) {
						System.out.println(d[i] + " " + d[j] + " " + d[k]);
					}
				}
			}
		}
		
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值