1.全网可达
在AR1上:[r1]interface g0/0/1
[r1-GigabitEthernet0/0/1]ip address 12.1.1.1 24
[r1-GigabitEthernet0/0/1]quit
[r1]ip route-static 23.1.1.0 24 12.1.1.2
[r1]ip route-static 32.1.1.0 24 12.1.1.2
[r1]ip route-static 34.1.1.0 24 12.1.1.2
[r1]ip route-static 46.1.1.0 24 12.1.1.2
在AR2上:[r2]interface g0/0/1
[r2-GigabitEthernet0/0/1]ip address 23.1.1.1 24
[r2-GigabitEthernet0/0/1]quit
[r2]interface g0/0/2
[r2-GigabitEthernet0/0/2]ip address 32.1.1.1 24
[r2-GigabitEthernet0/0/2]quit
[r2]ip route-static 34.1.1.0 24 23.1.1.2
[r2]ip route-static 34.1.1.0 24 32.1.1.2
[r2]ip route-static 46.1.1.0 24 23.1.1.2
[r2]ip route-static 46.1.1.0 24 32.1.1.2
在AR3上:[r3]interface g0/0/2
[r3-GigabitEthernet0/0/2]ip address 34.1.1.1 24
[r3-GigabitEthernet0/0/2]quit
[r3]ip route-static 46.1.1.0 24 34.1.1.2
[r3]ip route-static 12.1.1.0 24 23.1.1.1
[r3]ip route-static 12.1.1.0 24 32.1.1.1
在AR4上:[r4]interface g0/0/2
[r4-GigabitEthernet0/0/2]ip address 46.1.1.1 24
[r4-GigabitEthernet0/0/2]quit
[r4]interface g0/0/2
[r4-GigabitEthernet0/0/2]ip address 46.1.1.1 24
Error: The address already exists.
[r4-GigabitEthernet0/0/2]ip address 46.1.1.2 24
[r4-GigabitEthernet0/0/2]quit
在AR6上:[r6]interface g0/0/0
[r6-GigabitEthernet0/0/0]ip address 46.1.1.2 24
[r6-GigabitEthernet0/0/0]quit
[r6]ip route-static 12.1.1.0 24 46.1.1.1
[r6]ip route-static 23.1.1.0 24 46.1.1.1
[r6]ip route-static 32.1.1.0 24 46.1.1.1
[r6]ip route-static 34.1.1.0 24 46.1.1.1
2.pc1和pc2获取指定ip地址
[r1]interface g0/0/0
[r1-GigabitEthernet0/0/0]quit
[r1]dhcp enable
[r1]ip pool 1
[r1-ip-pool-1]network 172.16.1.0 mask 24
[r1-ip-pool-1]gateway-list 172.16.1.1
[r1-ip-pool-1]dns-list 8.8.8.8 114.114.114.114
[r1-ip-pool-1]static-bind ip-address 172.16.1.11 mac-address 5489-9817-0CD5
[r1-ip-pool-1]static-bind ip-address 172.16.1.13 mac-address 5489-9877-178B
[r1-ip-pool-1]quit
[r1]interface g0/0/0
[r1-GigabitEthernet0/0/0]dhcp select global
3.pc3和pc4不能获取250-254的地址
[r6]interface g0/0/1
[r6-GigabitEthernet0/0/1]quit
[r6]ip pool 2
[r6-ip-pool-2]network 192.168.1.0 mask 24
[r6-ip-pool-2]gateway-list 192.168.1.1
[r6-ip-pool-2]dns-list 8.8.8.8 114.114.114.114
[r6-ip-pool-2]excluded-ip-address 192.168.1.250 192.168.1.254
[r6-ip-pool-2]quit
[r6]interface g0/0/1
[r6-GigabitEthernet0/0/1]dhcp select global
4.32.1.1.0/24为备份路径
[r2]ip route-static 32.1.1.0 24 34.1.1.2 preference 61
5.尽量减少路由条目pc1访问pc3456时使用汇总路由
[r2]ip route-static 192.168.0.0 22 32.1.1.2