L1-023 输出GPLT

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL
//错误
#include<stdio.h>
#include<string.h>
int main(void){
char an[10000];
int countG=0,countP=0,countL=0,countT=0;
    scanf("%s",an);
    for(int i=0;an[i]!='\0';i++){
        if(an[i]=='G'||'g')countG++;
        if(an[i]=='P'||'p')countP++;
        if(an[i]=='L'||'l')countL++;
        if(an[i]=='T'||'t')countT++;
    }
   printf("%d %d %d %d",countG,countP,countL,countT);
    while(1){
if(countG!=0){printf("G");
countG--;}
if(countP!=0){printf("P");
countP--;}    
if(countL!=0){printf("L");
countL--;}
if(countT!=0){printf("T");
countT--;}
if(!countG&&!countP&&!countL&&!countT) break;
    }
    return 0;
}
//正确
#include <stdio.h>
#include <string.h>

int main(void) {
    char an[10000];
    int countG = 0, countP = 0, countL = 0, countT = 0;

    // 读取输入字符串
    scanf("%s", an);

    // 遍历字符串,统计每个字符的数量
    for (int i = 0; an[i] != '\0'; i++) {
        if (an[i] == 'G' || an[i] == 'g') countG++;
        if (an[i] == 'P' || an[i] == 'p') countP++;
        if (an[i] == 'L' || an[i] == 'l') countL++;
        if (an[i] == 'T' || an[i] == 't') countT++;
    }

  

    // 按顺序输出字符,直到所有字符都被输出
    while (countG > 0 || countP > 0 || countL > 0 || countT > 0) {
        if (countG > 0) {
            printf("G");
            countG--;
        }
        if (countP > 0) {
            printf("P");
            countP--;
        }
        if (countL > 0) {
            printf("L");
            countL--;
        }
        if (countT > 0) {
            printf("T");
            countT--;
        }
    }

    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小李,今天刷题了嘛

谢谢啦,随便写着玩,记录学习

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值