给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....
这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT
的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL
//错误
#include<stdio.h>
#include<string.h>
int main(void){
char an[10000];
int countG=0,countP=0,countL=0,countT=0;
scanf("%s",an);
for(int i=0;an[i]!='\0';i++){
if(an[i]=='G'||'g')countG++;
if(an[i]=='P'||'p')countP++;
if(an[i]=='L'||'l')countL++;
if(an[i]=='T'||'t')countT++;
}
printf("%d %d %d %d",countG,countP,countL,countT);
while(1){
if(countG!=0){printf("G");
countG--;}
if(countP!=0){printf("P");
countP--;}
if(countL!=0){printf("L");
countL--;}
if(countT!=0){printf("T");
countT--;}
if(!countG&&!countP&&!countL&&!countT) break;
}
return 0;
}
//正确
#include <stdio.h>
#include <string.h>
int main(void) {
char an[10000];
int countG = 0, countP = 0, countL = 0, countT = 0;
// 读取输入字符串
scanf("%s", an);
// 遍历字符串,统计每个字符的数量
for (int i = 0; an[i] != '\0'; i++) {
if (an[i] == 'G' || an[i] == 'g') countG++;
if (an[i] == 'P' || an[i] == 'p') countP++;
if (an[i] == 'L' || an[i] == 'l') countL++;
if (an[i] == 'T' || an[i] == 't') countT++;
}
// 按顺序输出字符,直到所有字符都被输出
while (countG > 0 || countP > 0 || countL > 0 || countT > 0) {
if (countG > 0) {
printf("G");
countG--;
}
if (countP > 0) {
printf("P");
countP--;
}
if (countL > 0) {
printf("L");
countL--;
}
if (countT > 0) {
printf("T");
countT--;
}
}
return 0;
}