作者 陈越
单位 浙江大学
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
#include <bits/stdc++.h>
using namespace std;
struct node{
int data;
node* lchild;
node* rchild;
};
int post[35],in[35];
node* create(int postl,int postr,int inl,int inr){
if(postl > postr){
return NULL;
}
node *root = new node; //把结构体的力量给我!!
root -> data = post[postr]; //这里是根,我的值放里面
int i;
for( i=inl ; i<=inr ;i++){
if(in[i] == post[postr]){ //由于是后序遍历,后序最后的是中序的根,所以冲刺,找,找根。
break;
}
}
int numleft = i - inl; //i - inl 表示从起始位置到根节点位置之间有多少个节点,即左子树的节点数量
root -> lchild = create(postl,postl+numleft-1,inl,i-1); //后序遍历的范围:[postl, postl + numleft - 1],中序遍历的范围:[inl, i - 1]
root -> rchild = create(postl+numleft,postr-1,i+1,inr);
return root;
}
int num=0,n;
void test(node *root){
queue<node*> q; //先进先出开队列
q.push(root);
while(!q.empty()){
node *now = q.front();
q.pop();
cout << now ->data;
num++;
if(num<n) cout <<" ";
if(now -> lchild!=NULL) q.push(now-> lchild);
if(now -> rchild!=NULL) q.push(now->rchild);
}
}
int main(){
cin >> n;
for(int i=0;i<n;i++){
cin >> post[i];
}
for(int i=0;i<n;i++){
cin >> in[i];
}
node *root = create(0,n-1,0,n-1);
test(root);
return 0;
}
记录一下