题目描述
设有N个选手进行循环比赛,其中N=2^m,要求每名选手要与其他N−1名选手都赛一次,每名选手每天比赛一次,循环赛共进行N−1天,要求每天没有选手轮空。
输入
输入:M。
输出
输出:表格形式的比赛安排表。一行各数据间用一个空格隔开。
样例输入
3
样例输出
1 2 3 4 5 6 7 8
2 1 4 3 6 5 8 7
3 4 1 2 7 8 5 6
4 3 2 1 8 7 6 5
5 6 7 8 1 2 3 4
6 5 8 7 2 1 4 3
7 8 5 6 3 4 1 2
8 7 6 5 4 3 2 1
#include<bits/stdc++.h>
using namespace std;
const int Maxn=33, Maxm=5;
int matchlist[Maxn][Maxn];
int m;
int main()
{
cin>>m;
int n=1<<m; // qiu 2^m
int k=1, half=1;
matchlist[0][0]=1;
while (k<=m)
{
for (int i=0;i<half;i++)
for (int j=0;j<half; j++)
{
matchlist[i][j+half]=matchlist[i][j]+half;
}
for (int i=0;i<half;i++)
for (int j=0;j<half;j++)
{
matchlist[i+half][j]=matchlist[i][j+half];
matchlist[i+half][j+half]=matchlist[i][j];
}
half*=2;
k++;
}
for (int i=0;i<n;i++)
{
for (int j=0;j<n;j++)
cout<<matchlist[i][j]<<" ";
cout<<endl;
}
return 0;
}