This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
#include<stdio.h>
int main(){
int k,t;
int count = 0;
float c[10001] = {0};
float m;
scanf("%d", &k);
//多项式的指数就当作数组下标记录系数的索引
for(int i = 0; i < k; i++){
scanf("%d %f", &t, &m);
c[t] += m;
}
scanf("%d", &k);
for(int i = 0; i < k; i++){
scanf("%d %f", &t, &m);
c[t] += m;
}
for(int i = 0; i < 10001; i++){
if(c[i] != 0)
count++;
}
printf("%d", count);
for(int i = 10000; i >=0; i--){
if(c[i] != 0){
printf(" %d %.1f", i, c[i]);
}
}
return 0;
}