POJ 2505 A multiplication game(博弈)

本文介绍了一种基于乘法的游戏博弈策略,通过分析游戏规则,总结出一套有效的胜负判断算法。该算法通过不断将给定数值除以18,直至其小于18,并根据最终结果确定先手或后手是否能赢得比赛。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either
Stan wins.
or
Ollie wins.
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

思路

可以乘2-9排,那么如果给定的数是2-9,先手肯定可以赢。如果是大于9计算一下到多少,后手肯定可以赢,因为先手乘最少的2,后手乘最大的9,10-18后手肯定可以赢。18-162先手赢,162-324,后手赢
规律,所给数一直除18直到小于18,最后小于等于9,先手赢,大于9,后手赢

代码

#include<iostream>
using namespace std;

int main()
{
	double n;
	while(cin>>n)
	{
		while(n>18)
			n/=18;
		if(n<=9)
			cout<<"Stan wins."<<endl;
		else
			cout<<"Ollie wins."<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值