We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex
Input
There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.
Output
For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.
Sample Input
4 1 90 90 90 90 6 1 60 60 60 60 60 60
Sample Output
2.000 2.598
题解:给出n边形,然后将n边形分成n个三角形,告诉你每个三角形的一个角度,然后告诉你三角形边长。让你求出n边形的面积。
其实就是求三角形面积 s=a*b*sinc/2;
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
double pi=acos(-1);
int main()
{
int n,a;
while(~scanf("%d %d",&n,&a))
{
int b[12];
double s=0;
for(int i=0; i<n; i++)
{
scanf("%d",&b[i]);
double f=double(b[i])/double(180)*pi;
s=s+sin(f);
}
double sum=double(a)*double(a)*s/2.0;
printf("%.3lf\n",sum);
}
return 0;
}