1381. a*b

1381. a*b
Total:4745Accepted:1275Rating:
2.7/5.0(26 votes)
   
Time Limit: 1sec    Memory Limit:32MB
Description

Give two positive integers a and b, please help us calculate a*b.

Input

The first line of the input is a positive integer T. T is the number of test cases followed.

Each test case contain two integer a,b (0<=a<=10^100, 0<=b<=10,000) given in one line.

Output

The output of each test case should consist of one line, contain the result of a*b.

Sample Input
 Copy sample input to clipboard
12 7
Sample Output
14

Problem Source: Algorithm Course Examination 2006



// source code of submission 1085278, Zhongshan University Online Judge System
#include <iostream>
#include <string>
using namespace std;

int main()
{
	int n;
	cin>>n;
	while (n--)
	{
		int a[101]={0},b,c[120]={0};
		string s1;
		cin>>s1>>b;
		if(s1[0]!='0'&&b!=0)
		{
			for(int i=s1.length()-1;i>=0;i--)
				a[i]=s1[s1.length()-i-1]-'0';
			for(int i=0;i<=s1.length()-1;i++)
				c[i]=a[i]*b;
			if(s1.length()!=1)
			{
				for(int i=0;i<=s1.length()-2;i++)
				{
					c[i+1]+=c[i]/10;
					c[i]%=10;
				}
				for(int i=s1.length()-1;i>=0;i--)
					cout<<c[i];
				cout<<endl;
			}
			else cout<<(s1[0]-'0')*b<<endl;
		}
		else cout<<0<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值