1082 Calendar Game

Calendar Game
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2802 Accepted: 1196

Description

Adam and Eve enter this year's ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

Input

The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.

Output

Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO".

Sample Input

3 
2001 11 3 
2001 11 2 
2001 10 3 

Sample Output

YES
NO
NO
如果一个节点的所有后续节点都是必胜态,该节点为必败态,否则该节点为必胜态。也即是说,只要有一个后续节点是必败态,该节点就是必胜态。
最后一天为必败态,倒数第一天为必胜态,从后往前推。
#include<iostream>
#include<cstdio>
using namespace std;
int state[2002][13][32];//0必败,1必胜
int month[2][13]={0,31,28,31,30,31,30,31,31,30,31,30,31,0,31,29,31,30,31,30,31,31,30,31,30,31};
int leap(int y)
{
    if((y%4==0&&y%100!=0)||(y%400==0)) return 1;
    return 0;
}
int _legal(int y,int m,int d)
{
   if(d>month[leap(y)][m]) return 0;
   return 1;
}
int legal(int y,int m,int d)
{
   if(y==2001)
   {
       if(m>11) return 0;
       if(m==11&&d>4) return 0;
   }
   if(d>month[leap(y)][m]) return 0;
   return 1;
}
void init()
{
    //state[2001][11][4]=0;
    for(int i=5;i<=30;i++) state[2001][11][i]=1;
    for(int i=1;i<=31;i++) state[2001][12][i]=1;
    for(int i=2001;i>=1900;i--)
    {
        for(int j=12;j>=1;j--)
        {
            for(int k=31;k>=1;k--)
            {
                if(legal(i,j,k))
                {
                    int cnt=0;
                    int y,m,d;//(i,j,k)的后续局面(y,m,d);
                    y=i,m=j,d=k+1;//后一天
                    if(d>month[leap(y)][m])
                    {
                        d=1;
                        m++;
                        if(m>12)
                        {
                            y++;
                            m=1;
                        }
                    }
                    if(state[y][m][d]) cnt++;
                    y=i,m=j+1,d=k;//下个月的今天
                    if(m>12) m=1,y++;
                    if(_legal(y,m,d))
                    {
                        if(state[y][m][d]&&cnt) state[i][j][k]=0;
                        else state[i][j][k]=1;
                    }
                    else
                    {
                        if(cnt) state[i][j][k]=0;
                        else state[i][j][k]=1;
                    }
                }
            }
        }
    }
}
int main()
{
    init();
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        int y,m,d;
        scanf("%d%d%d",&y,&m,&d);
        if(state[y][m][d]) printf("YES/n");
        else printf("NO/n");
    }
    return 0;
}
//更好的程序参见
//http://blog.youkuaiyun.com/logic_nut/archive/2009/10/22/4711518.aspx
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值