Digital Roots
Time Limit: 1 Sec Memory Limit: 64 MBDescription
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24 39 0
Sample Output
6 3
HINT
最后的数根等于该数所有位上的数相加后的和对九取余(但是有两种情况需要特判一下,1、如果输入的数为零,那么最后答案就是零。2、如果计算之后的结果位零,则答案位九),为了避免特判的麻烦,可以这样求解 答案
ans=(sum-1)%9+1。
现在解释一下为什么可以这样做,因为加和sum可以看成由若干个九和一位小于十的数组成,所以sum对九取余,即为答案。
#include<stdio.h>
int main()
{
long long int ans;
int i,p,j;
char con[10009];
while(scanf("%s",con)!=EOF)
{
ans=0;
if(con[0]=='0')
break;
for(i=0;i<=10008;i++)
if(con[i]==0)
break;
else
ans+=con[i]-48;
ans=ans%9;
if(ans==0)
printf("9\n");
else
printf("%lld\n",ans);
}
return 0;
}
或者
#include<stdio.h>
int main()
{
long long int ans;
int i,p,j;
char con[10009];
while(scanf("%s",con)!=EOF)
{
ans=0;
if(con[0]=='0')
break;
for(i=0;i<=10008;i++)
if(con[i]==0)
break;
else
ans+=con[i]-48;
printf("%d\n",(ans-1)%9+1);
}
return 0;
}