3067 Japan 树状数组

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8532 Accepted: 2290

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source

WA了差不多10次。。。。。悲剧啊。。。。虽然N,M是到1000,可是节点的数量是会超INT的范围的。。。。接着就是节点是否重合的问题。。。。这个真的很难办。。。。最后我直接将Y俺减序排列,接着X按减序排,最后记录下每个X重合的数目,因为X的范围是1000,接着得到SUM,再减去每个X重合的数目Y  (Y-1)Y/2,这一条是画图看出来的

#include<stdio.h>

#include<algorithm>

#include<string.h>

using namespace std;

struct t

{

    int x,y;

    __int64 value;

}e[1000010];

int n,m,k;

__int64 tree[1005];

bool cmp(t a, t b)

{

    if(a.y!=b.y)  return a.y>b.y;

    return a.x>b.x;

}

inline int Lowbit(int x)

{

    return x&(-x);

}

void Update(int x)

{

    for(int i=x;i<=1000;i+=Lowbit(i))

    tree[i]++;

}

__int64 Getsum(int x)

{

    __int64 temp=0;

    for(int i=x;i>0;i-=Lowbit(i))

         temp+=tree[i];

    return temp;

}

int main()

{

    int T,cas=1;

    scanf("%d",&T);

    while(T--)

    {

        memset(tree,0,sizeof(tree));

        scanf("%d%d%d",&n,&m,&k);

        for(int i=1;i<=k;i++)

           scanf("%d%d",&e[i].x,&e[i].y);

        sort(e+1,e+k+1,cmp);

        for(int i=1;i<=k;i++)

        {

            e[i].value=Getsum(e[i].x);

            Update(e[i].x);

        }

        int d=0;

        __int64 sum=0;

        int ss[1001]={0};

        for(int i=1;i<=k;i++)

        {

            ss[e[i].x]++;

            sum+=e[i].value;

         }

         for(int i=1;i<1001;i++)

         {

             sum-=(ss[i])*(ss[i]-1)/2;

         }

        printf("Test case %d: %I64d/n",cas++,sum);

    }

    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值