Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 13340 | Accepted: 3790 |
Description
There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:
1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).
In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.
Input
Output
Sample Input
2 2 4 C 1 1 2 P 1 2 C 2 2 2 P 1 2
Sample Output
2 1
Source
#include<iostream>
using namespace std;
#define MAXN 100001
struct Seg_Tree //线段树的结构
{
Seg_Tree *leftptr,*rightptr;//线段树两个子树的指针
int left,right,color;//两个节点的表示范围和节点的颜色
};
int L,T,O,cnt;//输入的长度L,颜色的种类T和操作的数目O
int numOfTree;//树的当前数目
Seg_Tree tree[MAXN*4],*Root; //所有的节点和根节点
Seg_Tree* CreatNode() //创建新节点
{
Seg_Tree *p= &tree[numOfTree++];//创建一个新的指针,指向数组里的一个元素
memset(p,0,sizeof(Seg_Tree));
return p;
}
Seg_Tree* CreatTree(int s,int e)//创建树
{
Seg_Tree* root=CreatNode();//创立结点
root->left=s;
root->right=e;//为左右的范围设立值
if(s!=e)
{
int mid=(s+e)/2;//递归分解,节点表示的范围越来越小
root->leftptr=CreatTree(s,mid);//子树表示的范围约是父节点的1/2
root->rightptr=CreatTree(mid+1,e);
}
return root;
}
bool odd(int n)//判断这个颜色是否为单色
{
return (n&(n-1))==0;
}
void updateTree(Seg_Tree *root,int s,int e,int color)//更新线段树
{
if(s<=root->left&&e>=root->right)//如果此节点表示的范围完全被包含,则整个被重新改变颜色
{
root->color=color;
return;
}
if(root->color==color) return;//节点颜色不需要被改变
if(odd(root->color)) //如果节点为单色,则在上一次改变中,子树没有被改变,这个重新赋值
{
root->leftptr->color=root->color;
root->rightptr->color=root->color;
}
int mid=(root->left+root->right)/2;
if(s<=mid) updateTree(root->leftptr,s,e,color); //如果左子树需要被改变
if(e>mid) updateTree(root->rightptr,s,e,color); //右子树被改变
root->color=root->leftptr->color|root->rightptr->color; //父节点的颜色等于2个子树的或和
}
void Query(Seg_Tree* root,int s,int e,int &cnt) //查询
{
if(s<=root->left&&e>=root->right) //如果节点被完全包括
{
cnt=cnt|root->color;
return;
}
if(odd(root->color))
{
cnt=cnt|root->color;
return;
}
int mid=(root->left+root->right)/2;
if(s<=mid) Query(root->leftptr,s,e,cnt); //查询左子树
if(e>mid) Query(root->rightptr,s,e,cnt); //查询右子树
}
int cal(int n) //计算颜色数量
{
int cnt=0;
while(n>0)
{
if(n%2) cnt++;
n>>=1;
}
return cnt;
}
int main()
{
numOfTree=0;
scanf("%d%d%d",&L,&T,&O);
Root=CreatTree(1,L);
updateTree(Root,1,L,1);
char cmd;
int s,e,c;
while (O--)
{
scanf(" %c",&cmd);
if(cmd=='C')
{
scanf("%d%d%d",&s,&e,&c);
if(s>e) swap(s,e);
updateTree(Root,s,e,1<<(c-1));
}
else
{
cnt=0;
scanf("%d%d",&s,&e);
if(s>e) swap(s,e);
Query(Root,s,e,cnt);
printf("%d/n",cal(cnt));
}
}
//int i;cin>>i;
return 0;
}