【SPFA】poj2387

Til the Cows Come Home

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90
 
大意:求1到n的最短路
又是一道模板题…………
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;;
const long N = 1100, M = 4100;
const long INF = 1073741824;
struct ty
{
    long t, w, next;
};
long n, t, m;
long head[N];
ty edge[M];
long q[1000000];
bool v[N];
long dist[N];
void insertedge(long x, long y, long z, long k)
{
    edge[k].t = y;
    edge[k].w = z;
    edge[k].next = head[x];
    head[x] = k;
}
void init()
{
    memset(head, 0, sizeof(head));
    memset(edge, 0, sizeof(edge));
    m = 0;
    for (long i = 1; i <= t; i++)
    {
        long x, y, z;
        scanf("%d%d%d", &x, &y, &z);
        insertedge(x, y, z, ++m);
        insertedge(y, x, z, ++m);
    }
}
void spfa()
{
    memset(v, 0, sizeof(v));
    memset(dist, 127, sizeof(dist));
    long l = 0, r = 0;
    q[r++] = 1;
    v[1] = true;
    dist[1] = 0;
    while (l < r)
    {
        long x = q[l++];
        v[x] = false;
        for (long i = head[x]; i != 0; i = edge[i].next)
        {
            long t = edge[i].t;
            if (dist[t] > dist[x] + edge[i].w)
            {
                dist[t] = dist[x] + edge[i].w;
                if (!v[t])
                {
                    q[r++] = t;
                    v[t] = true;
                }
            }
        }
    }
    cout << dist[n] << endl;
}
int main()
{
    while(scanf("%d%d", &t, &n) != EOF)
    {
        init();
        spfa();
    }
    return 0 ;
}


### 关于 POJ 2092 的问题分析 POJ 平台上的题目通常涉及算法设计与实现,而编号为 2092 的具体题目并未在提供的引用中明确提及。然而,可以通过已知的相关资源和经验推测其可能的解决方法。 #### 差分约束系统的应用 如果假设 POJ 2092 类似于其他差分约束类问题,则可以参考类似的解决方案[^3]。这类问题的核心在于通过构建不等式组来表示变量之间的关系,并将其转化为图论中的短路径或长路径问题。例如: - 对于条件 \( P \),\( A - B = X \) 可以被分解为两个不等式: \( A - B \geq X \) 和 \( A - B \leq X \)[^3]。 - 对于条件 \( V \),则有 \( A - B \geq 1 \)。 这些不等式可以用边的形式表示在一个加权图中,随后运行 SPFA 或 Bellman-Ford 算法检测是否存在满足所有约束的解集。特别需要注意的是引入一个超级源点连接到所有节点,从而保证整个图连通性。 #### 动态规划 vs 常规方法对比 针对某些特定类型的优化问题,动态规划 (Dynamic Programming, DP) 方法能够显著提高效率并减少冗余计算量。相比之下,传统方式可能会因为重复子问题而导致性能瓶颈。尽管当前讨论未直接指向 POJ 2092 是否适用此技术路线,但从更广泛意义上看,DP 是处理复杂状态转移的有效工具之一[^2]。 以下是基于上述理论框架的一个简单 Python 实现例子用于验证可行性: ```python from collections import deque def spfa(n, edges): INF = float('inf') dist = [-INF] * n in_queue = [False] * n q = deque() s = 0 # Super source node index. # Initialize distances from super-source to all nodes as zero. for i in range(n): if not in_queue[i]: q.append(i) in_queue[i] = True while q: u = q.popleft() in_queue[u] = False for v, w in edges.get(u, []): if dist[v] < dist[u] + w: dist[v] = dist[u] + w if not in_queue[v]: q.append(v) in_queue[v] = True return any(dist[i] >= INF / 2 for i in range(1,n)) # Example usage with dummy data representing constraints... if __name__ == "__main__": N = 5 # Number of variables plus one extra 'super' start point. E = {0:[(i,0)for i in range(1,N)]} # Connects every variable directly via weight-zero links. result = spfa(N,E) print("Positive cycle exists:",result) ``` 以上代码片段展示了如何运用队列辅助广度优先搜索(SPFA)寻找潜在正向循环逻辑链路结构。这一步骤对于判定是否有可行方案至关重要。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值