While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
/*
N 牧场 M 代表路径 W代表虫洞
F 农场
S ,E T 起点 终点 时间 双向路
W:代表 单项路从S->E 回溯到Ts
*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define N 505
#define M 2600
#define W 202
#define inf 0x3f3f3f3f
int map[N][N],n,w,m,f,flag;
void floyd()
{
int i,j,k;
for(k=1;k<=n;k++)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(map[i][j]>map[i][k]+map[k][j])
{
map[i][j]=map[i][k]+map[k][j];
}
}
if(map[i][i]<0)
{
flag=1;
break;
}
}
}
}
int main()
{
//freopen("c.in","r",stdin);
//freopen("c.out","w",stdout);
cin>>f;
while(f--)
{
cin>>n>>m>>w;
for(int i=1;i<=n;i++)//初始化
{
for(int j=1;j<=n;j++)
{
if(i==j) map[i][j]=0;
else map[i][j]=map[j][i]=inf;
}
}
int a,b,c;
for(int i=0;i<m;i++)//双向路
{
cin>>a>>b>>c;
if(map[a][b]>c)//判断更新条件
{
map[a][b]=map[b][a]=c;
}
}
for(int i=0;i<w;i++)//单项路
{
cin>>a>>b>>c;
map[a][b]=-c;
}
flag=0;
floyd();
if(flag) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}return 0;
}