1007. Maximum Subsequence Sum (25)
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:10 -10 1 2 3 4 -5 -23 3 7 -21Sample Output:
10 1 4
这是一道相当经典的题目,目的是求序列中子序列的最大和以及对应的子序列头和子序列尾,当序列都是负数时,规定和为0,并且输出整个序列头和序列尾对应的数,输入数据时注意输入为一个0序列的情况,(即0 0 0 0 0)
#include<vector>
#include<iostream>
using namespace std;
int main(){
int num,i,temp;
int star = 0,left,right,summax = -1,thismax = 0;
bool flag = false;
vector<int> seq;
cin>>num;
for ( i = 0 ; i < num ; i++ ){
cin>>temp;
if ( temp >= 0)
flag = true;
seq.push_back(temp);
}
for ( i = 0 ; i < num ; i++ ){
thismax += seq[i];
if (thismax < 0){
thismax = 0;
star = i + 1;
}
else if ( thismax > summax ){
summax = thismax;
left = seq[star];
right = seq[i];
}
}
if ( !flag )
cout<<0<<" "<<seq[0]<<" "<<seq[num-1];
else
cout<<summax<<" "<<left<<" "<<right;
return 0;
}