HDU1877 又一版 A+B

注意最大和最小值就OK了。

SampleInput:

8 1300 48
2 1 7
2 2147483647 2147483647
2 0 0
0

SampleOutput:

2504
1000
11111111111111111111111111111110
0

#include <iostream>
#define MAXN 35
using namespace std;

int main()
{
	//freopen("in.txt","r",stdin);
	long long m,a,b;
	int res[MAXN];
	
	while(cin>>m, m!=0)
	{
		cin >> a >> b;
		long long sum = a+b;		
		
		int loc = 0;
		if(sum != 0){
			while(sum != 0)
		    {
	    		res[loc++] = sum%m;
	    		sum /= m;
	    	}
	    	for(int i=loc-1; i>=0; i--)
	    		cout << res[i];
		}
		else cout << sum;
   		cout << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值