HDU 5625 Clarke and chemistry

Clarke and chemistry


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 58    Accepted Submission(s): 30



Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a junior student and took a chemistry exam.
But he did not get full score in this exam. He checked his test paper and found a naive mistake, he was wrong with a simple chemical equation balancer.
He was unhappy and wanted to make a program to solve problems like this.
This chemical equation balancer follow the rules:
Two valences A combined by |A| elements and B combined by |B| elements.
We get a new valence C by a combination reaction and the stoichiometric coefficient of C is 1 . Please calculate the stoichiometric coefficient a of A and b of B that aA+bB=C,  a,bN .
 

Input
The first line contains an integer T(1T10) , the number of test cases.
For each test case, the first line contains three integers A,B,C(1A,B,C26) , denotes |A|,|B|,|C| respectively.
Then A+B+C lines follow, each line looks like X c , denotes the number of element X of A,B,C respectively is c . ( X is one of 26 capital letters, guarantee X of one valence only appear one time, 1c100 )
 

Output
For each test case, if we can balance the equation, print a and b . If there are multiple answers, print the smallest one, a is smallest then b is smallest. Otherwise print NO.
 

Sample Input
  
  
2 2 3 5 A 2 B 2 C 3 D 3 E 3 A 4 B 4 C 9 D 9 E 9 2 2 2 A 4 B 4 A 3 B 3 A 9 B 9
 

Sample Output
  
  
2 3 NO Hint: The first test case, $a=2, b=3$ can make equation right. The second test case, no any answer.
 

#include<cstring>
#include<iostream>
using namespace std;

int num1[30];
int num2[30];
int sum[30];
bool check(int a,int b){
    int i;
    for(i=0;i<26;i++){
        if(a*num1[i]+b*num2[i]!=sum[i]){
            return false;
        }
    }
    return true;
}

int main(){
    int T,t,flag,a,b,c,i,j;
    char x;
    cin>>T;
    while(T--){
        flag=0;
        memset(num1,0,sizeof(num1));
        memset(num2,0,sizeof(num2));
        memset(sum,0,sizeof(sum));
        cin>>a>>b>>c;
        while(a--){
            cin>>x>>t;
            num1[x-'A']=t;
        }
        while(b--){
            cin>>x>>t;
            num2[x-'A']=t;
        }
        while(c--){
            cin>>x>>t;
            sum[x-'A']=t;
        }
        for(i=1;i<=100;i++){
            for(j=1;j<=100;j++){
                if(check(i,j)){
                    flag=1;
                    a=i;
                    b=j;
                    break;
                }
            }
            if(flag){
                break;
            }
        }
        if(flag){
            cout<<a<<" "<<b<<endl;
        }
        else{
            cout<<"NO"<<endl;
        }
    }
    return 0;
}



内容概要:本文详细介绍了CCF-GESP认证的学习资源与知识点指南,分为官方资源与平台、知识点学习与解析、备考策略与工具、实战项目与进阶资源以及学习工具推荐五个部分。官方资源包括CCF数字图书馆提供的免费真题库、一站式学习平台和GESP官网的最新真题下载及考试环境说明。知识点学习部分涵盖Python、C++和图形化编程(Scratch)的核心内容与实战案例。备考策略方面,提出了基础、强化和冲刺三个阶段的分阶段计划,并强调了在线题库模拟测试与社区交流的重要性。实战项目与进阶资源则为不同编程语言提供了具体的应用场景,如Python的智能客服机器人和C++的并行编程与嵌入式开发。最后,推荐了多种学习工具,如代码编辑器VS Code、模拟考试平台和社区支持渠道。 适合人群:准备参加CCF-GESP认证考试的考生,特别是对Python、C++或Scratch编程语言有兴趣的学习者。 使用场景及目标:①帮助考生系统化地学习官方资源,熟悉考试形式和内容;②通过分阶段的备考策略,提高应试能力和编程技能;③利用实战项目和进阶资源,增强实际编程经验和解决复杂问题的能力。 阅读建议:建议考生按照文章中的分阶段备考策略逐步推进学习进度,充分利用官方提供的资源进行练习和模拟测试,并积极参与社区交流以获取更多备考经验和疑难解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值