Double Queue
Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:
Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy. Input Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority. Output For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output. Sample Input 2 1 20 14 1 30 3 2 1 10 99 3 2 2 0 Sample Output 0 20 30 10 0 Source |
题目:http://poj.org/problem?id=3481
分析:这题可以用SBT来解,只要维护一棵平衡树,每次删掉最大或最小就行。。。
代码:
#include<cstdio>
using namespace std;
const int mm=1111111;
int L[mm],R[mm],S[mm],V[mm],K[mm];
int a,b,c,root,tt,sum;
void Right_Rotate(int &t)
{
int k=L[t];
L[t]=R[k];
R[k]=t;
S[k]=S[t];
S[t]=S[L[t]]+S[R[t]]+1;
t=k;
}
void Left_Rotate(int &t)
{
int k=R[t];
R[t]=L[k];
L[k]=t;
S[k]=S[t];
S[t]=S[L[t]]+S[R[t]]+1;
t=k;
}
void maintain(int &t,bool flag)
{
if(flag)
if(S[R[R[t]]]>S[L[t]])Left_Rotate(t);
else if(S[L[R[t]]]>S[L[t]])
Right_Rotate(R[t]),Left_Rotate(t);
else return;
else
if(S[L[L[t]]]>S[R[t]])Right_Rotate(t);
else if(S[R[L[t]]]>S[R[t]])
Left_Rotate(L[t]),Right_Rotate(t);
else return;
maintain(L[t],0);
maintain(R[t],1);
maintain(t,0);
maintain(t,1);
}
void Insert(int &t,int v,int k)
{
if(t)
{
++S[t];
if(v<V[t])Insert(L[t],v,k);
else Insert(R[t],v,k);
maintain(t,v>=V[t]);
}
else
{
S[t=++tt]=1;
V[t]=v;
K[t]=k;
L[t]=R[t]=0;
}
}
int outmax()
{
int p=root,t=root;
while(R[t])p=t,t=R[t];
if(t!=p)R[p]=L[t];
else root=L[t];
return K[t];
}
int outmin()
{
int p=root,t=root;
while(L[t])p=t,t=L[t];
if(t!=p)L[p]=R[t];
else root=R[t];
return K[t];
}
int main()
{
sum=root=tt=S[0]=0;
while(scanf("%d",&a),a)
{
if(a==1)
{
scanf("%d%d",&b,&c);
Insert(root,c,b);
++sum;
}
else if(sum)
{
if(a==2)printf("%d\n",outmax());
else printf("%d\n",outmin());
--sum;
}
else puts("0");
}
return 0;
}