自定义博客皮肤VIP专享

*博客头图:

格式为PNG、JPG,宽度*高度大于1920*100像素,不超过2MB,主视觉建议放在右侧,请参照线上博客头图

请上传大于1920*100像素的图片!

博客底图:

图片格式为PNG、JPG,不超过1MB,可上下左右平铺至整个背景

栏目图:

图片格式为PNG、JPG,图片宽度*高度为300*38像素,不超过0.5MB

主标题颜色:

RGB颜色,例如:#AFAFAF

Hover:

RGB颜色,例如:#AFAFAF

副标题颜色:

RGB颜色,例如:#AFAFAF

自定义博客皮肤

-+
  • 博客(42)
  • 资源 (1)
  • 收藏
  • 关注

原创 深入浅出URL编码

一、问题:        编码问题是JAVA初学者在web开发过程中经常会遇到问题,网上也有大量相关的文章介绍,但其中很多文章并没有对URL中使用了中文等非ASCII的字符造成服务器后台程序解析出现乱码的问题作出准确的解释和说明。本文将详细介绍由于在URL中使用了中文等非ASCII的字符造成乱码的问题。 1、在URL中中文字符通常出现在以下两个地方:(1)、Query String中的参数...

2012-06-28 13:46:17 223

原创 Python 编码风格指南中译版

http://www.elias.cn/Python/PythonStyleGuide

2012-02-12 18:09:14 196

原创 activemq 重新连接的机制

最近一个项目要用到ActiveMq,并且需要最大程度的保证消息不丢失。以前对activeMq不是很熟悉,完全是摸着石头过河,目前基本配置都搞定了。只是对于它的自动重连一直找不到好的解决办法,我希望的效果是当一个broker(假设只有这一个,没有备用的)如果异常down掉的话,那么监听程序能够等待broker重启后再自动重新连接。看了它的文档似乎 设置一下failover:(tcp://loca...

2011-12-30 18:09:24 532

原创 linux上mysql5.5.8安装详解

MySQL5.5源码安装和以前的5.x有区别,5.x使用autotool编译,新版的5.5使用CMake编译 1.1. Cmake的安装 http://www.cmake.org/cmake/resources/software.html 下载源码包,安装cmake方法和其他的安装相同,解压,配置,编译,安装 cmake安装 1 [root@woyoo s...

2011-10-27 17:51:17 246

原创 python 文件过滤器

python实用技巧 : Filtering os.walk ''' Created on Mar 7, 2010 @author: Diego 需求: 得到某个目录...

2011-10-24 15:36:31 474

原创 HttpClient学习

HttpClient支持的HTTP方法有8种,下面分述之。 1、Options   HTTP方法Options用来向服务器发送请求,希望获得针对由请求URL(request url)标志的资源在请求/应答的通信过程可以使用的功能选项。通过这个方法,客户端可以在采取具体行动之前,就可对某一资源决定采取什么动作和/或以及 一些必要条件,或者了解服务器提供的功能。这个方法最典型的应用,...

2011-09-29 12:37:11 204

原创 HttpClient容易忽视的细节——连接关闭

Java代码    HttpClient client =  new  HttpClient();   HttpMethod method = new  GetMethod( "http://www.apache.org" );   try  {     client.executeMethod(method);   ...

2011-09-29 12:22:44 133

原创 httpclient多线程下载(分段下载)实践

多线程是指的分段下载,利用http请求头里加入Range,分段请求数据下载,然后把数据合并,此处是用的java的RandomAccessFile类来写目标文件

2011-09-24 20:30:55 718 1

原创 Python环境设置

有时候我们正在修改或调试的程序会是一个库,为修改方便,我们可能不大希望把它放到 site-packages 下面,而是更愿意把它保留在原始的工程目录中,以方便 IDE 和版本控制工具进行管理。那么怎么能让 Python 运行环境找到这个库呢? 原理上, Python 运行环境查找库文件时本质是对 sys.path 列表的遍历,如果我们想给运行环境注册新的类库进来, 要么得用代码给 s...

2011-09-24 20:13:52 452

原创 HTTP状态码

定义   HTTP状态码 (HTTP Status Code)是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC 2616 规范定义的,并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。   所有状态码的第一个数字代表了响应的五种状态之一。 1xx 消息   这一类型的状态码,代表请求已被接受,需要继续...

2011-09-23 12:13:29 155

原创 maven 打包的问题

如果package出现--source1.3 的类似问题,那么在pom.xml中加入如下插件配置:   <build>     <plugins>       <plugin>         <groupId>org.apache.maven.plugins</groupId>         <artifactId&...

2011-09-21 20:20:39 138

命令行运行python时找不到模块的问题“ImportError: No module named”

自己写了一个python脚本,使用的是eclipse + pydev插件的IDE 在IDE中执行没问题,在命令行中,就出现“ImportError: No module named” 错误 项目的目录结构   执行python LogAnalysis.py报错 ImportError: No module named com.util 在LogAnalysis.py中加入sys.p...

2011-09-21 16:09:55 2317

原创 Python 中读写文件的安全写法 (异常处理)

f = open( "hello.txt") try :     for line in f:         print linefinally :     f.close()     对文件的打开和读写部分要分开处理异常:若文件未成功打开,则只需进行普通处理,不必进行close()操作,不要把open语句写到try语句块中 ...

2011-09-21 15:50:00 323

原创 Python类的专用方法

http://wangtong40.iteye.com/blog/376025

2011-09-20 11:54:59 158

原创 收集了一些常用的API参考文档

http://www.iteye.com/topic/1114603

2011-09-15 15:06:42 155

扩展TokenFilter,实现二次分词

经过paoding分词后,再对每个token进行2次分词,此处是二元切分法   public class MyCJKFilter extends TokenFilter {     private TermAttribute termAtt = (TermAttribute) addAttribute(TermAttribute.class);;     private OffsetAtt...

2011-09-01 16:00:29 202

原创 paoding动态加载词典

关于paoding动态加载词典,网上多数是如下代码,但是我下载了2.0.4的源码后,发现Paoding.java 这个文件时空的,不存在这个方法 Paoding paoding = PaodingMaker.make(); paoding.stopAutoDetecting();//关闭自动词典监测,使用手动检测   用 paoding.dic.detector.interval ...

2011-09-01 14:18:04 200

原创 Java正则表达式入门

众所周知,在程序开发中,难免会遇到需要匹配、查找、替换、判断字符串的情况发生,而这些情况有时又比较复杂,如果用纯编码方式解决,往往会浪费程序员的时间及精力。因此,学习及使用正则表达式,便成了解决这一矛盾的主要手段。  大 家都知道,正则表达式是一种可以用于模式匹配和替换的规范,一个正则表达式就是由普通的字符(例如字符a到z)以及特殊字符(元字符)组成的文字模式,它 用以描述在查找文字主体时待...

2011-08-12 15:17:40 130

solr的unique-key的fieldtype必须为string类型

今天发现了一个以前没有注意的问题,solr的schema.xml配置文件中,unique-key的field必须是string类型,否则会报错。 org.apache.solr.common.SolrException: QueryElevationComponent requires the schema to have a uniqueKeyField implemented using S...

2011-08-09 18:51:39 1004

原创 memcached的key的限制

用xmemcached客户端,对于key的内容有限制,不能包含如下字符:   描述  |  ascii码值   空格 --> 32 \r --> 10 \n --> 13  还有一个是方块,无法复制  --> 0...

2011-07-30 11:51:28 171

原创 Unicode正则表达式

http://www.unicode.org/reports/tr18/

2011-07-28 13:48:01 322

原创 正则替换字符串的全角、半角标点符号

class  T {    public   static   void  main(String[] args) {     String str =  "!!!!去符号标号!!当然。!!..**半角" ;     System.out.println(str);     System.out.println(str....

2011-07-28 11:51:26 309

原创 MyEclipse8.6安装svn插件

安装subclipse, SVN 插件 1、从官网下载site-1.6.16.zip文件,网址是:subclipse.tigris.org, 2、从中解压出features与plugins文件夹,复制到C:\MyEclipse\myPlugin\svn里面,其它的*.xml文件不要。 3、在C:\MyEclipse\MyEclipse8.6\dropins下新建文件svn.link,...

2011-07-26 15:52:19 125

原创 logback日志样例

<?xml version="1.0" encoding="UTF-8"?>  <configuration>  <jmxConfigurator />  <appender name="stdout" class="ch.qos.logback.core.ConsoleAppender"> 

2011-07-20 10:56:05 185

原创 Xmemcached与Spring 3.0的集成

昨天收到一个xmc的issue报告,大概的意思是将Xmemcached 与spring 2.5集成没有任何问题,但是将spring升级到3.0就会抛出一个异常,并且spring容器无法正常启动,异常信息类似“Couldn 't find a destroy method named ' shutdown' on bean XMemcachedClientFactoryBean”。更详细的情...

2011-07-18 11:47:48 131

原创 solrj+spellcheck

package com.doculibre.constellio.servlets; import java.net.MalformedURLException; import java.util.Iterator; import java.util.List; import java.util.Map; import java.util.Map.Entry; import...

2011-07-05 18:44:41 176

原创 solr整合paoding

1.         下载 paoding-analysis-2.0.4-beta.zip http://code.google.com/p/paoding/downloads/list   2.         解压压缩包至 paoding-analysis-2.0.4-beta 3.         ...

2011-07-04 18:03:26 208

原创 Solr 使用自定义 Query Parser-2

Solr 使用自定义 Query Parser

2011-07-04 17:57:38 148

原创 solr 使用自定义的 QueryParser

如果想让 solr 有更加强大的功能或在查询时做一些特别的处理。可以在 solrconfig.xml 里注册自定义的 QueryParser(查询解析器),这是 solr 1.3 的新功能(插件功能),如: < queryParser   name = "mylucene"   class = "org.apache.solr.search.MyQParserPlug...

2011-07-04 17:51:48 223

原创 HTTP 状态代码

如果向您的服务器发出了某项请求要求显示您网站上的某个网页(例如,当用户通过浏览器访问您的网页或在 Googlebot 抓取该网页时),那么,您的服务器会返回 HTTP 状态代码以响应该请求。 此状态代码提供了有关请求状态的信息,且为 Googlebot 提供了有关您网站和请求的网页的信息。 一些常见的状态代码为: 200 - 服务器成功返回网页 404 - 请求的网页不存...

2011-06-21 09:16:43 128

原创 如何正确的使用java.util.ConcurrentLinkedQueue

Java 5 中提供了 ConcurrentLinkedQueue 来简化并发操作。但是有一个问题:使用了这个类之后是否意味着我们不需要自己进行任何同步或加锁操作了呢? 我在网上找到了这个:http://stackoverflow.com/questions/435069/java-util-concurrentlinkedqueue/435941 // StackOverflow...

2011-06-08 16:39:53 133

原创 学习网站

[url]http://www.hadoopor.com/[/url] [url]http://www.hadooper.cn/[/url] [url]http://hadoop.apache.org/[/url]

2011-05-12 15:05:22 115

原创 不错的maven网站

[url]http://www.juvenxu.com/[/url]

2011-05-06 14:29:39 142

原创 nginx负载均衡 tomcat集群 memcache共享session

要集群tomcat主要是解决SESSION共享的问题,因此我利用memcached来保存session,多台TOMCAT服务器即可共享SESSION了。 你可以自己写tomcat的扩展来保存SESSION到memcached。 这里推荐使用memcached-session-manager这个开源项目(http://code.google.com/p/memcached-sessio...

2011-05-06 14:23:25 138

原创 Solr Multicore 结合 Solr Distributed Searching 切分大索引来搜索

Solr Multicore 结合 Solr Distributed Searching 切分大索引来搜索 发表于:2009年1月14日 | 分类:Solr | 标签: distributed, multicore, solr | views(2,705) 版权信息: 可以任意转载, 转载时请务必以超链接形式标明文章原文出处, 即下面的声明. 原文出处:http://blog.che...

2011-05-06 14:21:58 134

原创 Linux查看文件夹大小

du -sh 查看当前文件夹大小 du -sh * | sort -n 统计当前文件夹(目录)大小,并按文件大小排序 附送: du -sk filename 查看指定文件大小 Linux:ls以K、M、G为单位查看文件大小 Linux:ls以K、M、G为单位查看文件大小。 #man ls …… -h, --human-readable pri...

2011-05-06 14:21:15 175

原创 Spring C3P0 配置文件

...

2011-05-06 14:20:16 159

原创 HTML在线编辑器

[url]http://www.kindsoft.net/demo.php[/url]

2011-05-06 14:19:00 200

原创 c3p0配置文件说名

##配置除user,password,minpoolsize,maxpoolsize的参数 ##[注意] 整数值不能有空格 #初始化时获取三个连接,取值应在minPoolSize与maxPoolSize之间。Default: 3 c3p0.initialPoolSize=10 #当连接池中的连接耗尽的时候c3p0一次同时获取的连接数。Default: 3 c3p0.acquire...

2011-05-06 14:16:59 176

原创 c3p0 - JDBC3 Connection and Statement Pooling

[url][size=large]http://www.mchange.com/projects/c3p0/index.html#contents[/size][/url]

2011-05-06 14:15:50 117

struts1.3.8标准源码

源码,供学习源码,供学习源码,供学习源码,供学习源码,供学习源码,供学习源码,供学习源码,供学习源码,供学习

2008-11-18

空空如也

TA创建的收藏夹 TA关注的收藏夹

TA关注的人

提示
确定要删除当前文章?
取消 删除