<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[eric_wyf的专栏]]></title><description><![CDATA[]]></description><link>https://blog.youkuaiyun.com/eric_wyf</link><language>zh-cn</language><generator>https://blog.youkuaiyun.com/</generator><copyright><![CDATA[Copyright &copy; eric_wyf]]></copyright><item><title><![CDATA[深入浅出URL编码]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84241022</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84241022</guid><author>eric_wyf</author><pubDate>Thu, 28 Jun 2012 13:46:17 +0800</pubDate><description><![CDATA[

一、问题：        编码问题是JAVA初学者在web开发过程中经常会遇到问题，网上也有大量相关的文章介绍，但其中很多文章并没有对URL中使用了中文等非ASCII的字符造成服务器后台程序解析出现乱码的问题作出准确的解释和说明。本文将详细介绍由于在URL中使用了中文等非ASCII的字符造成乱码的问题。
1、在URL中中文字符通常出现在以下两个地方：(1)、Query String中的参数...]]></description><category></category></item><item><title><![CDATA[Python 编码风格指南中译版]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84152099</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84152099</guid><author>eric_wyf</author><pubDate>Sun, 12 Feb 2012 18:09:14 +0800</pubDate><description><![CDATA[http://www.elias.cn/Python/PythonStyleGuide]]></description><category></category></item><item><title><![CDATA[activemq 重新连接的机制]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84122808</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84122808</guid><author>eric_wyf</author><pubDate>Fri, 30 Dec 2011 18:09:24 +0800</pubDate><description><![CDATA[
最近一个项目要用到ActiveMq，并且需要最大程度的保证消息不丢失。以前对activeMq不是很熟悉，完全是摸着石头过河，目前基本配置都搞定了。只是对于它的自动重连一直找不到好的解决办法，我希望的效果是当一个broker（假设只有这一个，没有备用的）如果异常down掉的话，那么监听程序能够等待broker重启后再自动重新连接。看了它的文档似乎 设置一下failover:(tcp://loca...]]></description><category></category></item><item><title><![CDATA[linux上mysql5.5.8安装详解]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84055059</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84055059</guid><author>eric_wyf</author><pubDate>Thu, 27 Oct 2011 17:51:17 +0800</pubDate><description><![CDATA[
MySQL5.5源码安装和以前的5.x有区别，5.x使用autotool编译，新版的5.5使用CMake编译
1.1. Cmake的安装
http://www.cmake.org/cmake/resources/software.html

下载源码包，安装cmake方法和其他的安装相同，解压，配置，编译，安装
cmake安装





1


[root@woyoo s...]]></description><category></category></item><item><title><![CDATA[python 文件过滤器]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84052824</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84052824</guid><author>eric_wyf</author><pubDate>Mon, 24 Oct 2011 15:36:31 +0800</pubDate><description><![CDATA[
                            python实用技巧 : Filtering os.walk
                        

                        
                        '''

 Created on Mar 7, 2010
 @author: Diego
 需求: 得到某个目录...]]></description><category></category></item><item><title><![CDATA[HttpClient学习]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84041234</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84041234</guid><author>eric_wyf</author><pubDate>Thu, 29 Sep 2011 12:37:11 +0800</pubDate><description><![CDATA[HttpClient支持的HTTP方法有8种，下面分述之。

1、Options

　　HTTP方法Options用来向服务器发送请求，希望获得针对由请求URL(request 
url)标志的资源在请求/应答的通信过程可以使用的功能选项。通过这个方法，客户端可以在采取具体行动之前，就可对某一资源决定采取什么动作和/或以及
一些必要条件，或者了解服务器提供的功能。这个方法最典型的应用，...]]></description><category></category></item><item><title><![CDATA[HttpClient容易忽视的细节——连接关闭]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84041227</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84041227</guid><author>eric_wyf</author><pubDate>Thu, 29 Sep 2011 12:22:44 +0800</pubDate><description><![CDATA[


Java代码 
 




HttpClient client = 
new
 HttpClient();  



HttpMethod method = new
 GetMethod(
&quot;http://www.apache.org&quot;
);  



try
 {  



  client.executeMethod(method);  
...]]></description><category></category></item><item><title><![CDATA[httpclient多线程下载(分段下载)实践]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84022372</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84022372</guid><author>eric_wyf</author><pubDate>Sat, 24 Sep 2011 20:30:55 +0800</pubDate><description><![CDATA[多线程是指的分段下载，利用http请求头里加入Range，分段请求数据下载，然后把数据合并，此处是用的java的RandomAccessFile类来写目标文件]]></description><category></category></item><item><title><![CDATA[Python环境设置]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84022370</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84022370</guid><author>eric_wyf</author><pubDate>Sat, 24 Sep 2011 20:13:52 +0800</pubDate><description><![CDATA[有时候我们正在修改或调试的程序会是一个库，为修改方便，我们可能不大希望把它放到 site-packages 下面，而是更愿意把它保留在原始的工程目录中，以方便 IDE 和版本控制工具进行管理。那么怎么能让 Python 运行环境找到这个库呢？

原理上， Python 运行环境查找库文件时本质是对 sys.path 列表的遍历，如果我们想给运行环境注册新的类库进来，


要么得用代码给 s...]]></description><category></category></item><item><title><![CDATA[HTTP状态码]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84021725</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84021725</guid><author>eric_wyf</author><pubDate>Fri, 23 Sep 2011 12:13:29 +0800</pubDate><description><![CDATA[
定义

　　HTTP状态码
（HTTP Status Code）是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC 2616 规范定义的，并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。
　　所有状态码的第一个数字代表了响应的五种状态之一。


1xx 消息

　　这一类型的状态码，代表请求已被接受，需要继续...]]></description><category></category></item><item><title><![CDATA[maven 打包的问题]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84020829</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84020829</guid><author>eric_wyf</author><pubDate>Wed, 21 Sep 2011 20:20:39 +0800</pubDate><description><![CDATA[如果package出现--source1.3 的类似问题，那么在pom.xml中加入如下插件配置：
 
&amp;lt;build&amp;gt;
    &amp;lt;plugins&amp;gt;
      &amp;lt;plugin&amp;gt;
        &amp;lt;groupId&amp;gt;org.apache.maven.plugins&amp;lt;/groupId&amp;gt;
        &amp;lt;artifactId&amp;...]]></description><category></category></item><item><title><![CDATA[命令行运行python时找不到模块的问题“ImportError: No module named”]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84020701</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84020701</guid><author>eric_wyf</author><pubDate>Wed, 21 Sep 2011 16:09:55 +0800</pubDate><description><![CDATA[自己写了一个python脚本，使用的是eclipse + pydev插件的IDE
在IDE中执行没问题，在命令行中，就出现“ImportError: No module named”
错误
项目的目录结构

 
执行python LogAnalysis.py报错 ImportError: No module named com.util
在LogAnalysis.py中加入sys.p...]]></description><category></category></item><item><title><![CDATA[Python 中读写文件的安全写法 (异常处理) ]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84020687</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84020687</guid><author>eric_wyf</author><pubDate>Wed, 21 Sep 2011 15:50:00 +0800</pubDate><description><![CDATA[f = open(
&quot;hello.txt&quot;)
try
:
    for
 line in
 f:
        print linefinally
:
    f.close()

 
 
对文件的打开和读写部分要分开处理异常：若文件未成功打开，则只需进行普通处理，不必进行close()操作,不要把open语句写到try语句块中
...]]></description><category></category></item><item><title><![CDATA[Python类的专用方法]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84019984</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84019984</guid><author>eric_wyf</author><pubDate>Tue, 20 Sep 2011 11:54:59 +0800</pubDate><description><![CDATA[http://wangtong40.iteye.com/blog/376025]]></description><category></category></item><item><title><![CDATA[收集了一些常用的API参考文档]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84017588</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84017588</guid><author>eric_wyf</author><pubDate>Thu, 15 Sep 2011 15:06:42 +0800</pubDate><description><![CDATA[http://www.iteye.com/topic/1114603]]></description><category></category></item><item><title><![CDATA[扩展TokenFilter，实现二次分词]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84011205</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84011205</guid><author>eric_wyf</author><pubDate>Thu, 01 Sep 2011 16:00:29 +0800</pubDate><description><![CDATA[经过paoding分词后，再对每个token进行2次分词，此处是二元切分法
 
public class MyCJKFilter extends TokenFilter {
    private TermAttribute termAtt = (TermAttribute) addAttribute(TermAttribute.class);;
    private OffsetAtt...]]></description><category></category></item><item><title><![CDATA[paoding动态加载词典]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/84011103</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/84011103</guid><author>eric_wyf</author><pubDate>Thu, 01 Sep 2011 14:18:04 +0800</pubDate><description><![CDATA[关于paoding动态加载词典，网上多数是如下代码，但是我下载了2.0.4的源码后，发现Paoding.java 这个文件时空的，不存在这个方法
Paoding paoding = PaodingMaker.make();
		paoding.stopAutoDetecting();//关闭自动词典监测，使用手动检测
 
用
paoding.dic.detector.interval
...]]></description><category></category></item><item><title><![CDATA[Java正则表达式入门]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/83985291</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/83985291</guid><author>eric_wyf</author><pubDate>Fri, 12 Aug 2011 15:17:40 +0800</pubDate><description><![CDATA[众所周知，在程序开发中，难免会遇到需要匹配、查找、替换、判断字符串的情况发生，而这些情况有时又比较复杂，如果用纯编码方式解决，往往会浪费程序员的时间及精力。因此，学习及使用正则表达式，便成了解决这一矛盾的主要手段。
 大
家都知道，正则表达式是一种可以用于模式匹配和替换的规范，一个正则表达式就是由普通的字符（例如字符a到z）以及特殊字符（元字符）组成的文字模式，它
用以描述在查找文字主体时待...]]></description><category></category></item><item><title><![CDATA[solr的unique-key的fieldtype必须为string类型]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/83983484</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/83983484</guid><author>eric_wyf</author><pubDate>Tue, 09 Aug 2011 18:51:39 +0800</pubDate><description><![CDATA[今天发现了一个以前没有注意的问题，solr的schema.xml配置文件中，unique-key的field必须是string类型，否则会报错。
org.apache.solr.common.SolrException: QueryElevationComponent requires the schema to have a uniqueKeyField implemented using S...]]></description><category></category></item><item><title><![CDATA[memcached的key的限制]]></title><link>https://blog.youkuaiyun.com/eric_wyf/article/details/83978639</link><guid>https://blog.youkuaiyun.com/eric_wyf/article/details/83978639</guid><author>eric_wyf</author><pubDate>Sat, 30 Jul 2011 11:51:28 +0800</pubDate><description><![CDATA[用xmemcached客户端，对于key的内容有限制，不能包含如下字符：
 
描述  |  ascii码值
 
空格 --&amp;gt; 32
\r --&amp;gt; 10
\n --&amp;gt; 13
 还有一个是方块，无法复制  --&amp;gt; 0...]]></description><category></category></item></channel></rss>