There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output should contain the maximal sum of guests' ratings.
Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0Sample Output
5
题意 :有n个人要开1个party ,他们每个人有一个欢乐值,他们可能会有上司和下属,为了保证玩的开心 ,party上不能有直属的上司和下属,现在选一些人去参加 求最大欢乐总值;
解 定义 dp[i][0]为第i个人不参加获得的最大欢乐值 dp[i][1]为第i个人参加获得的最大欢乐值
若j是i的下属
dp[i][0]+=max(dp[j][0],dp[j][1]) +=是因为1个上次可能有多个下属,若i不参加 则j可以参加或者j不参加,取最大欢乐值
dp[i][1]+=dp[j][0] i参加 j不能参加
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stack>
#include<vector>
#include<map>
#define nn 100001
#define mm 500001
#define inff 0x3fffffff
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")
int vis[nn];
int dp[nn][2];
int n,num;
int p[nn];
struct node
{
int en,next;
}e[nn];
int init()
{
memset(p,-1,sizeof(p));
memset(dp,0,sizeof(dp));
memset(vis,0,sizeof(vis));
num=0;
}
int add(int st,int en)
{
e[num].en=en;
e[num].next=p[st];
p[st]=num++;
}
int dfs(int u,int pre)
{
vis[u]=1;
for(int i=p[u];i+1;i=e[i].next)
{
int v=e[i].en;
if(!vis[v])
{
dfs(v,u);
dp[u][1]+=dp[v][0];
dp[u][0]+=max(dp[v][0],dp[v][1]);
}
}
}
int main()
{
int a,b;
while(~scanf("%d",&n))
{
init();
for(int i=1;i<=n;i++)
scanf("%d",&dp[i][1]);
while(scanf("%d%d",&a,&b)&&a+b)
{
add(a,b);
add(b,a);
}
dfs(1,-1);
printf("%d\n",max(dp[1][0],dp[1][1]));
}
}