C - Constructing Roads

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179

import java.io.BufferedInputStream;
import java.util.PriorityQueue;
import java.util.Scanner;

public class Main{ 
	/* [8.3~8.9]最小生成树
	 * A - Jungle Roads 
	 * */
	static final int N=(int)1e2+10,M=N<<1;
	static int []fa,x,y,Size;
	static int n;
	static int sum;
	static int g[][];
	static PriorityQueue<node>q=new PriorityQueue<node>();
	
	public static void main(String[] args) {
		
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		int e,v,s,b;
		init();
//		int t=sc.nextInt();
		while(sc.hasNext()) {
			n=sc.nextInt();
			kruskal_init(n);
			//记录边的信息
			for(int i=1;i<=n;i++) {
				for(int j=1;j<=n;j++) {
					g[i][j]=sc.nextInt();
				}
			}
			int Q=sc.nextInt();
			for(int i=1;i<=Q;i++) {
				e=sc.nextInt();
				v=sc.nextInt();
				g[e][v]=g[v][e]=0;
			}
			for(int i=1;i<=n;i++) {
				for(int j=1;j<i;j++) {
					q.add(new node(i,j,g[i][j]));
				}
			}
			Kruskal();
		}
	}
	static void Kruskal() {
		//合并
		while(!q.isEmpty()) {
//			Union(q.poll());
			node no=q.poll();
			int l=find(no.s);
			int r=find(no.e);
			if(l!=r) {
				fa[l]=r;
				sum+=no.v;
			}
		}
		System.out.println(sum);
	}
	static void kruskal_init(int n) {
		q.clear();
		//并查集初始化。
		for(int i=0;i<=n;i++) {
			fa[i]=i;
//			Size[i]=1;
		}
		sum=0;
	}
	static double col(int i,int j) {
		return Math.sqrt(Math.pow(x[i]-x[j], 2)+Math.pow(y[i]-y[j], 2));
	}
	static int find(int x) {
		if(fa[x]==x) return x;
		return (fa[x]=find(fa[x]));
	}
	static void init() {
//		Size=new int[N];
//		x=new int [N];
//		y=new int [N];
		fa=new int [N];
		g=new int [N][N];
	}
	static class node implements Comparable<node>{
		int s,e;
//		double v;
//		public node(int s,int e,double v) {
//			this.s=s;this.e=e;this.v=v;
//		}
		
		int v;
		public node(int s,int e,int v) {
			this.s=s;this.e=e;this.v=v;
		}
		public int compareTo (node o) {
			if(this.v>o.v) return 1;
			else if(this.v==o.v) return 0;
			return -1;
//			if( this.u<o.u) return ;
		}
	}
}
### 构造对象的概念 在编程中,构造对象通常涉及创建类的一个实例并初始化其属性。这一过程通过调用类中的特殊方法——即构造函数来完成。构造函数的主要作用是在对象被创建时执行必要的初始化操作。 #### 面向对象编程中的构造器 在一个典型的面向对象语言(如Java或SystemVerilog)中,可以通过定义一个具有特定名称的构造函数来实现对象的构建[^1]。例如,在引用的内容中提到 `class ClassA` 的定义中隐含了一个构造逻辑的存在。虽然未显式展示,但在实际应用中,构造函数可能类似于以下形式: ```verilog class ClassA; int value; function new(int init_value); this.value = init_value; // 初始化成员变量 endfunction : new endclass ``` 上述代码展示了如何通过 `new` 函数作为构造函数来初始化 `value` 属性。当一个新的 `ClassA` 对象被创建时,会自动调用此构造函数,并传入初始值以设置该对象的状态。 #### 数据结构与算法视角下的对象构造 从数据结构的角度来看,构造对象不仅限于简单的赋值行为,还涉及到复杂的数据管理策略。例如,数组和链表这样的基础数据结构可以用来表示更高级别的抽象数据类型,比如栈、队列或者二叉树等[^2]。这些复杂的结构往往也需要在其内部维护状态信息,因此它们的构造过程可能会更加复杂。 考虑下面这个例子,它演示了如何使用Python来构造一个基于列表实现的堆栈对象: ```python class Stack: def __init__(self): # 这是一个构造函数 self.items = [] # 初始化为空列表 def push(self, item): self.items.append(item) def pop(self): return self.items.pop() stack_instance = Stack() # 创建Stack的对象 stack_instance.push(10) print(stack_instance.pop()) # 输出最后压入的元素 ``` 在这个案例里,`__init__()` 方法扮演着构造函数的角色,负责建立新的 `Stack` 实例及其关联的存储空间。 #### 动态链接库(DLLs)上下文中对象的构造注意事项 如果讨论的是动态链接库环境下的对象构造,则需要注意额外的因素,例如依赖关系管理和权限问题。假如遇到错误消息 `"Cannot open DllXYZ.dll for writing"` ,这表明可能存在文件访问冲突或者是缺少某些运行所需的外部DLL支持等问题[^4]。解决这类情况需要确保所有必需的组件都已正确定位并且可由应用程序加载。 ### 总结 综上所述,无论在哪种具体的编程场景下,“如何构造一个对象”的答案都会围绕几个核心要素展开:一是明确目标类型的特性;二是合理设计用于启动新实体生命周期的操作序列;三是妥善处理任何可能出现的技术障碍。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值