Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。
现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
Input
本题目包含多组数据,请处理到文件结束。 每组数据第一行包含两个正整数N和M(0< N<200,0< M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。 接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B< N,A!=B,0< X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。 再接下一行有两个整数S,T(0<=S,T< N),分别代表起点和终点。
Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
Sample Output
2
-1
Source
2008浙大研究生复试热身赛(2)——全真模拟,by-linle
题解
priority_queue默认大顶堆,我们要先对其排序变成小顶堆。
Dijkstra算法也适用于无向图。但不适用于有负权边的图。
#include <cstdio>
#include <queue>
#include <cstring>
#include <vector>
using namespace std;
struct Node
{
int e;//有向边终点
int w;//weight权值
/*bool operator < (const Node &ohther)const{
return w > ohther.w;
}*/
};
struct cmp{
bool operator()(const Node &a,const Node &b)
{//运算符重载,使优先队列中最小的先出列
return a.w>b.w;
}
};
int main()
{
int N,M,s,t;
while(~scanf("%d%d",&N,&M))
{
priority_queue<Node,vector<Node>,cmp> que;
vector<vector<Node> > v;//构造邻接表
v.resize(N+1);
bool used[210]={0};
Node p;
int s,t;
while(M--){
int A,B,C;
scanf("%d%d%d",&A,&B,&C);
//双向道路,可以很坑。
p.e=B;
p.w=C;
v[A].push_back(p);
p.e=A;
v[B].push_back(p);
}
scanf("%d%d",&s,&t);
p.e=s;
p.w=0;
que.push(p);
while(!que.empty()){
p=que.top();que.pop();
used[p.e]=true;//一定要写在外面
if(p.e==t) break;//到达t点即可结束
for(int i=0,j=v[p.e].size();i<j;i++){
Node q;
q.e=v[p.e][i].e;
if(used[q.e]) continue;//过滤重复的
q.w=p.w+v[p.e][i].w;
que.push(q);
}
}
if(p.e!=t) p.w=-1;
printf("%d\n",p.w);
}
}