Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 36962 | Accepted: 14918 |
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output
1 3 0
Source
从头到尾彻底理解KMP:http://blog.youkuaiyun.com/v_july_v/article/details/7041827
import java.io.*;
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
int n=sc.nextInt();
sc.nextLine();
for(int o=1;o<=n;o++){
String pat=sc.nextLine();
String txt=sc.nextLine();
int count=0;
int[]next=makeNext(pat);//创建匹配字符串的next数组
int t_length=txt.length();
int p_length=pat.length();
int j=0;
for(int i=0;i<t_length;i++){
while(j>0&&txt.charAt(i)!=pat.charAt(j)){
j=next[j];//当匹配失败时,回退j
}
if(txt.charAt(i)==pat.charAt(j)){
j++;//如果当前字符匹配,j++往后找
}
if(j==p_length){
count++;
j=next[j];//找到了,count++过以后将当作没有匹配到,回退j
}
}
System.out.println(count);
}
}
public static int[] makeNext(String s){
int s_length=s.length();
int[] next=new int [s_length+1];
int j=0;
int k=-1;
next[0]=-1;
while(j<s_length){
if(k==-1||s.charAt(j)==s.charAt(k)){
next[++j]=++k;
}
else
k=next[k];
}
return next;
}
}
</span>