原题链接:PAT 1112 Stucked Keyboard (20分)
On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.
Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.
Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest
we know that the keys i
and e
might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest
.
Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.
Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.
Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest
题目大意:
现在有一把有坏键的键盘,按到坏键的话他会重复输出k次。
请你根据输出的字符串以及坏键会重复输出的次数k,判断键盘上的按键以及原本应该输出的正确的字符串。
注意:
- 可能前面判断为坏的按键在后面证明它其实是好的,只是他前面恰好按了k的整数倍。
- 最后输出正确字符串时,坏键也需要输出一次。
- 存储ans的时候不要用set,set内部会自动排序导致结果出错
方法一:map
思路:
用一个map来存储是否是好键,遍历一遍字符串,当其中一个字符连续出现的次数不是k的整数倍时他就是好的
然后输出的时候别忘了坏键也要输出一次。
C++ 代码:
// pat_a_1112
#include <iostream>
#include <algorithm>
#include <string>
#include <unordered_map>
#include <vector>
using namespace std;
const int maxn = 1010;
unordered_map<char, bool> isGood, vis;// isGood是否好键 vis是否访问过
vector<char> ans; // 存放坏键
int main() {
int k;
string str;
cin >> k >> str;
int len = str.size();
// 遍历一遍 找出好的键
for (int i = 0; i < len; i++) {
int j = i + 1;
while (j < len && str[i] == str[j]) j++;
if((j - i) % k != 0) isGood[str[i]] = true; //重复出现的次数不是k的整数倍就是好键
i = j - 1;
}
// 再遍历一遍 将坏键放入ans
for (int i = 0; i < len; i++) {
// 坏键
if (isGood[str[i]] == false) {
// 若未访问,放入ans, 标记已访问
if(vis[str[i]] == false){
ans.push_back(str[i]);
vis[str[i]] = true;
}
// 跳过接下来的k-1个字符
i = i + k - 1;
}
}
// 输出坏键
for(int i = 0; i < ans.size(); i++ )
cout << ans[i];
puts("");
// 输出正确字符串
for (int i = 0; i < len; i++) {
printf("%c", str[i]);
if(isGood[str[i]] == false)
i = i + k - 1;
}
return 0;
}