哈夫曼树

(1)九度上的练习题,通过这个练习题把哈夫曼树复习一遍,并编码实现:

题目描述:

哈夫曼树,第一行输入一个数n,表示叶结点的个数。需要用这些叶结点生成哈夫曼树,根据哈夫曼树的概念,这些结点有权值,即weight,题目需要输出所有结点的值与权值的乘积之和。

输入:

输入有多组数据。
每组第一行输入一个数n,接着输入n个叶节点(叶节点权值不超过100,2<=n<=1000)。

输出:

输出权值。

样例输入:
5  
1 2 2 5 9
样例输出:
37
(2)代码实现

#include <algorithm>
#include <iostream>
#include <string.h>
#include <stdlib.h>
 
#define MAXSIZE 1000
 
using namespace std;
 
struct TreeNode
{
   int value;
   TreeNode* left;
   TreeNode* right;
};
 
int compare(const void* a, const void* b)
{
    return ((*(TreeNode**)a)->value - (*(TreeNode**)b)->value);
}
 
TreeNode* ConstructHuffman(TreeNode** nodeArray, int n)
{
    int count = n;
    while(count > 1)
    {
        qsort(nodeArray,count, sizeof(TreeNode*), compare);
        int temp1 = nodeArray[0]->value;
        int temp2 = nodeArray[1]->value;
 
        TreeNode* parent = new TreeNode;
        parent->left = nodeArray[0];
        parent->right = nodeArray[1];
        parent->value = temp1+temp2;
 
        nodeArray[0] = parent;
        nodeArray[1] = nodeArray[count-1];
        count--;
    }
    return nodeArray[0];
}
void PrintPreTree(TreeNode* node)
{
    cout<<node->value<<endl;
    if(node->left != NULL)
        PrintPreTree(node->left);
    if(node->right != NULL)
        PrintPreTree(node->right);
}
 
void DeleteTree(TreeNode* node)
{
    if(node->left != NULL)
        DeleteTree(node->left);
    if(node->right != NULL)
        DeleteTree(node->right);
    delete node;
    node = NULL;
}
 
void CountWeight(TreeNode* node, int high, int& total)
{
    if(node != NULL && node->left == NULL && node->right == NULL)
    {     
        //cout<<high<<" "<<node->value<<endl;
        total += (high*(node->value));
    }
    int currHigh = high;
    if(node->left != NULL)
        CountWeight(node->left, ++currHigh, total);
    currHigh = high;
    if(node->right != NULL)
        CountWeight(node->right, ++currHigh, total);
}
 
int main()
{
    int n;
    TreeNode** nodeArray= new TreeNode*[MAXSIZE];
    while(cin>>n)
    {
        memset(nodeArray, 0, sizeof(TreeNode*)*MAXSIZE);
        //初始化叶节点
        TreeNode* tempTreeNode = NULL;
        for(int i=0; i<n; ++i)
        {
            tempTreeNode = new TreeNode;
            tempTreeNode->left = NULL;
            tempTreeNode->right = NULL;
            cin>>tempTreeNode->value;
            nodeArray[i] = tempTreeNode;
        }
        TreeNode* root = ConstructHuffman(nodeArray, n);
        //PrintPreTree(root);
        int total = 0;
        CountWeight(root, 0, total);
        cout<<total<<endl;
        DeleteTree(root);
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值