hdu3466 Proud Merchants 0-1背包变形

Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11

  一个物品的体积是Pi,必须要有Qi的容量才能放进去,价值Vi。

  这题我的做法是设dp[i]是忽略了要求容量后的最大价值,并且只要找到一个最小花费能得到最大价值,后面的就不算了。要对q-p进行从大到小排序,保证不出现大的花费本来还可以更新最大价值,但在取了一个物品后没有更新到它。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cstdlib>
#include<cmath>
#define INF 0x3f3f3f3f
#define MAXN 5010
#define MAXM 50010
#define MAXNODE 4*MAXN
#define MOD 1000000000
#define eps 1e-9
typedef long long LL;
using namespace std;
int N,M,dp[MAXN],l[MAXN];
struct st{
    int v,w,need;
    bool operator < (const st& x) const{
        return need-v>x.need-x.v;
    }
}s[MAXN];
int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%d%d",&N,&M)!=EOF){
        for(int i=0;i<N;i++) scanf("%d%d%d",&s[i].v,&s[i].need,&s[i].w);
        sort(s,s+N);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<N;i++)
            for(int j=M;j>=s[i].need;j--) dp[j-s[i].need+s[i].v]=max(dp[j-s[i].need+s[i].v],dp[j-s[i].need]+s[i].w);
        int ans=0;
        for(int i=M;i>=0;i--) ans=max(ans,dp[i]);
        printf("%d\n",ans);
    }
    return 0;
}

  另一种做法是dp[i]表示要考虑要求容量的影响能装的最大价值,q-p从小到大排序,因为要确保算此时的状态时之前的状态都算过,每个物品能更新到的最小的地方就是q-p,这个越小就要越先算。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cstdlib>
#include<cmath>
#define INF 0x3f3f3f3f
#define MAXN 5010
#define MAXM 50010
#define MAXNODE 4*MAXN
#define MOD 1000000000
#define eps 1e-9
typedef long long LL;
using namespace std;
int N,M,dp[MAXN],l[MAXN];
struct st{
    int v,w,need;
    bool operator < (const st& x) const{
        return need-v<x.need-x.v;
    }
}s[MAXN];
int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%d%d",&N,&M)!=EOF){
        for(int i=0;i<N;i++) scanf("%d%d%d",&s[i].v,&s[i].need,&s[i].w);
        sort(s,s+N);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<N;i++)
            for(int j=M;j>=s[i].need;j--) dp[j]=max(dp[j],dp[j-s[i].v]+s[i].w);
        printf("%d\n",dp[M]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值