1028 List Sorting

1028 List Sorting (25 point(s))

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where Nis the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

注意点:

1. 输出标准格式的数字。%06d是输出6位,空缺补0,而%6d则补全空格。

2.  cmp函数可以直接写在sort()的参数列表当中。

sort(stu.begin(),stu.end(),[](const Student&s1,const Student&s2){
            return s1.id<s2.id;
        });

3. 注意string类是C++独有的,因此不可以用scanf()读入,如果用printf()输出,需要用c_str()转换成C风格字符串。 

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct record{
	int id;
	string name;
	int grade;
};
bool cmp1(record a,record b){
	return a.id<b.id;
}
bool cmp2(record a,record b){
	if(a.name!=b.name) return a.name<b.name;
	return a.id<b.id;
}
bool cmp3(record a,record b){
	if(a.grade!=b.grade) return a.grade<b.grade;
	return a.id<b.id;
}
record R[100001];
int main(void){
	int n,c;
	cin>>n>>c;
	for(int i=0;i<n;i++){
		cin>>R[i].id>>R[i].name>>R[i].grade; 
	}
	if(c==1) sort(R,R+n,cmp1);
	else if(c==2) sort(R,R+n,cmp2);
	else sort(R,R+n,cmp3); 
	for(int i=0;i<n;i++){
		printf("%06d %s %d\n",R[i].id,R[i].name.c_str(),R[i].grade);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值