1005 Spell It Right (20 point(s))

本文介绍了一个程序设计挑战,要求将输入的非负整数的各位数字相加,并将和的每一位用英文单词表示。文章详细展示了如何使用C++实现这一功能,包括字符串到数字的转换、求和以及英文单词的映射。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1005 Spell It Right (20 point(s))

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

注意点

1. do-while循环 

#include<iostream>
#include<cstring>
using namespace std;
string digit[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int arr[30];
int main(void)
{
	string in;
	cin>>in;
	int sum = 0;
	for(int i=0;i<in.length();i++){
		sum=sum+in[i]-'0';
	}
	int index = 0;
	do{
		int d = sum%10;
		arr[index] = d;
		index++;
		sum/=10;
	}while(sum>0);
	for(int i=index-1;i>=0;i--){
		if(i==0) cout<<digit[arr[i]].c_str();
		else cout<<digit[arr[i]].c_str()<<" ";
	}
	cout<<endl;
	return 0;
 } 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值