UVA 301 - Transportation

Transportation 

Ruratania is just entering capitalism and is establishing new enterprising activities in many fields including transport. The transportation company TransRuratania is starting a new express train from city A to city B with several stops in the stations on the way. The stations are successively numbered, city A station has number 0, city B station number m. The company runs an experiment in order to improve passenger transportation capacity and thus to increase its earnings. The train has a maximum capacity n passengers. The price of the train ticket is equal to the number of stops (stations) between the starting station and the destination station (including the destination station). Before the train starts its route from the city A, ticket orders are collected from all onroute stations. The ticket order from the station S means all reservations of tickets from S to a fixed destination station. In case the company cannot accept all orders because of the passenger capacity limitations, its rejection policy is that it either completely accept or completely reject single orders from single stations.

Write a program which for the given list of orders from single stations on the way from A to B determines the biggest possible total earning of the TransRuratania company. The earning from one accepted order is the product of the number of passengers included in the order and the price of their train tickets. The total earning is the sum of the earnings from all accepted orders.

Input

The input file is divided into blocks. The first line in each block contains three integers: passenger capacity n of the train, the number of the city B station and the number of ticket orders from all stations. The next lines contain the ticket orders. Each ticket order consists of three integers: starting station, destination station, number of passengers. In one block there can be maximum 22 orders. The number of the city B station will be at most 7. The block where all three numbers in the first line are equal to zero denotes the end of the input file.

Output

The output file consists of lines corresponding to the blocks of the input file except the terminating block. Each such line contains the biggest possible total earning.

Sample Input

10 3 4
0 2 1
1 3 5
1 2 7
2 3 10
10 5 4
3 5 10
2 4 9
0 2 5
2 5 8
0 0 0

Sample Output

19
34

================================

把搜索之前的状态保存在save数组中,每次回溯调回之前的状态


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n,sta,p,maxsum,vis[11];

struct ticket
{
    int start;
    int end;
    int num;
    int money;
}s[111];

bool check(int cur)
{
    for(int i=s[cur].start;i<s[cur].end;i++)
    {
        vis[i]+=s[cur].num;
        if(vis[i]>n)
            return 0;
    }
    return 1;
}

void dfs(int cur,int sum)
{
    //cout<<"cur="<<cur<<endl;
    if(cur==p)
    {
        if(sum>maxsum)
            maxsum=sum;
        //cout<<sum<<endl;
        return;
    }
    dfs(cur+1,sum);
    int save[11];
    memcpy(save,vis,sizeof(save));
    if(check(cur))
    {
        dfs(cur+1,sum+s[cur].money);
    }
    memcpy(vis,save,sizeof(save));
    return;
}

int main()
{
    while(~scanf("%d%d%d",&n,&sta,&p))
    {
        if(n==0&&sta==0&&p==0) break;
        memset(vis,0,sizeof(vis));
        maxsum=-1;
        for(int i=0;i<p;i++)
        {
            scanf("%d%d%d",&s[i].start,&s[i].end,&s[i].num);
            s[i].money=s[i].num*(s[i].end-s[i].start);
        }
        dfs(0,0);
        printf("%d\n",maxsum);
    }
    return 0;
}


### GIB-UVA ERP-BCI HDF5 文件格式及其处理方法 HDF5 是一种用于存储大量科学数据的文件格式,广泛应用于神经科学研究领域。对于 GIB-UVA ERP-BCI 数据集中的 HDF5 文件,通常包含了脑电图(EEG)信号以及其他元数据信息。以下是关于该类文件的一些重要细节以及如何对其进行处理的方法。 #### 1. HDF5 文件结构概述 HDF5 文件是一种分层的数据存储格式,类似于文件系统的目录树结构。它支持多种数据类型,包括数组、表格和字符串等。在 GIB-UVA ERP-BCI 的上下文中,这些文件可能包含以下内容: - **实验记录**:如时间戳、采样率和其他实验参数。 - **原始 EEG 数据**:多通道的时间序列数据。 - **事件标记**:表示刺激呈现或其他行为事件的时间点。 这种层次化的结构使得研究人员可以轻松访问特定部分的数据而无需加载整个文件[^3]。 #### 2. 处理 HDF5 文件所需的工具 为了读取和操作 HDF5 文件,可以使用 Python 中的 `h5py` 或 MATLAB 提供的相关库。下面是一个简单的例子展示如何利用 `h5py` 打开并探索一个 HDF5 文件的内容: ```python import h5py def explore_hdf5(file_path): with h5py.File(file_path, 'r') as f: print("Keys:", list(f.keys())) # 列出顶层组名 for key in f.keys(): item = f[key] if isinstance(item, h5py.Dataset): print(f"{key} is a dataset with shape {item.shape}") elif isinstance(item, h5py.Group): print(f"{key} is a group containing:") for sub_key in item.keys(): print(f" - {sub_key}") explore_hdf5('example.h5') ``` 上述脚本会打印出给定 HDF5 文件的所有顶级键,并区分它们是数据集还是子组[^4]。 #### 3. 内存管理注意事项 如果尝试运行某些大型模型(例如 DeepSeek-R1),可能会遇到内存不足的情况,正如引用中提到的例子所示[^2]。在这种情况下,建议采取以下措施来优化资源分配: - 使用更高效的算法减少计算需求; - 增加物理 RAM 或启用虚拟内存扩展; - 对于 GPU 加速环境,考虑调整批次大小或切换到较低精度浮点数运算模式(FP16 vs FP32)。 此外,在处理大尺寸的 HDF5 文件时也需要注意类似的性能瓶颈问题——可以通过逐块加载而非一次性全部载入的方式来缓解这一挑战[^5]。 #### 4. 特殊情况下的预处理技术 针对 BCI 应用场景下采集得到的高维时空域特征矩阵,往往还需要执行一系列标准化流程,比如去噪滤波器应用、基线校正以及重参考变换等等。具体实现取决于实际研究目标和个人偏好设置等因素影响。 --- ###
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值