Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 10320 Accepted Submission(s): 3923
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2 3 4
Sample Output
2 2HintIn the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
===========================
借鉴了下别人的思路:
http://blog.youkuaiyun.com/lovelyloulou/article/details/5237263
令num^num=10^n *a(科学计数法)
两边取对数: num*lg(num) = n + lg(a);
因为a<10,所以0<lg(a)<1
令x=n+lg(a); 则n为x的整数部分,lg(a)为x的小数部分
a=10(x-n)=10(x-int(x)))
再取a的整数部分即得num的最高位
log(n):以e为底的对数
log10(n):以10为底的对数
以a为底的对数用换底公式:log(n)/log(a)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int main()
{
int t;
double x;
long long n;
scanf("%d",&t);
while(t--)
{
scanf("%I64d",&n);
x=n*log10(n*1.0);
//cout<<x<<endl;
x-=(long long)x;
int a=pow(10.0,x);
printf("%d\n",a);
}
return 0;
}