poj 1251 Jungle Roads(最小生成树)

这里写图片描述
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

最小生成树的模板题,这里算是记录一下模板。

prim算法

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#define maxn 1005
using namespace std;

int mincost[maxn],visit[maxn];
int g[maxn][maxn];
int n,E;
int prim()
{
    memset(mincost,0x3f,sizeof(mincost));
    memset(visit,0,sizeof(visit));
    mincost[0]=0;   //放入0节点
    int res=0;
    while(true)
    {
        int v=-1;
        for(int i=0;i<n;i++)
            if(!visit[i]&&(v==-1||mincost[i]<mincost[v])) v=i;
        if(v==-1) break;
        visit[v]=true;
        res+=mincost[v];
        for(int i=0;i<n;i++)
            mincost[i]=min(mincost[i],g[i][v]);
    }
    return res;
}
int main()
{
    while(cin>>n)
    {
        if(n==0) break;
        memset(g,0x3f,sizeof(g));
        for(int i=0;i<n-1;i++)
        {
            int m,dis;
            char v;
            cin>>v>>m;
            for(int j=0;j<m;j++)
            {
                cin>>v>>dis;
                g[i][v-'A']=g[v-'A'][i]=dis;
            }
        }
        cout<<prim()<<endl;
    }
    return 0;
}

kruskal算法

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#define maxn 1005
using namespace std;
int f[maxn];
struct edge{
    int u,v,cost;
}e[maxn];
int n,E;
void init()
{
    for(int i=0;i<=n;i++)
        f[i]=i;
}
int getf(int x)
{
    if(x==f[x]) return x;
    else return f[x]=getf(f[x]);
}

int same(int x,int y)
{
    x=getf(x);
    y=getf(y);
    if(x==y) return 1;
    else return 0;
}

void unite(int x,int y)
{
    x=getf(x);
    y=getf(y);
    f[y]=x;
}

bool cmp(edge x,edge y)
{
    return x.cost<y.cost;
}
int kruskal()
{
    init();
    sort(e,e+E,cmp);
    int res=0;
    for(int i=0;i<E;i++)
    {
        if(!same(e[i].u,e[i].v))
        {
            unite(e[i].u,e[i].v);
            res+=e[i].cost;
        }
    }
    return res;
}
int main()
{
    while(cin>>n)
    {
        if(n==0) break;
        E=0;
        for(int i=0;i<n-1;i++)
        {
            int m,dis;
            char v;
            cin>>v>>m;
            for(int j=0;j<m;j++)
            {
                cin>>v>>dis;
                e[E].u=i;
                e[E].v=v-'A';
                e[E].cost=dis;
                E++;
            }
        }
        cout<<kruskal()<<endl;
    }
    return 0;
}
内容概要:本文探讨了在微电网优化中如何处理风光能源的不确定性,特别是通过引入机会约束和概率序列的方法。首先介绍了风光能源的随机性和波动性带来的挑战,然后详细解释了机会约束的概念,即在一定概率水平下放松约束条件,从而提高模型灵活性。接着讨论了概率序列的应用,它通过对历史数据分析生成多个可能的风光发电场景及其概率,以此为基础构建优化模型的目标函数和约束条件。文中提供了具体的Matlab代码示例,演示了如何利用CPLEX求解器解决此类优化问题,并强调了参数选择、模型构建、约束添加以及求解过程中应注意的技术细节。此外,还提到了一些实用技巧,如通过调整MIP gap提升求解效率,使用K-means聚类减少场景数量以降低计算复杂度等。 适合人群:从事电力系统研究、微电网设计与运营的专业人士,尤其是那些对风光不确定性建模感兴趣的研究者和技术人员。 使用场景及目标:适用于需要评估和优化含有大量间歇性可再生能源接入的微电网系统,旨在提高系统的经济性和稳定性,确保在面对风光出力波动时仍能维持正常运作。 其他说明:文中提到的方法不仅有助于学术研究,也可应用于实际工程项目中,帮助工程师们制定更为稳健的微电网调度计划。同时,文中提供的代码片段可供读者参考并应用于类似的问题情境中。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值