三道acm基础题 CSU-1000.1001.1002

1000: A+B (I)

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 6295   Solved: 1753

[ Submit][ Status]

Description

Your task is to Calculate a + b.

Input

Input contains multiple test cases. Each test case consists of a pair of integers a and b(0<=a,b<=20), separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 1

Sample Output

2

HINT

Source

[ Submit][ Status]

最基础的输入输出


#include<stdio.h>
using namespace std;
int main()
{

    int a,b;
    while(~scanf("%d%d",&a,&b))
    {

        printf("%d\n",a+b);
    }
    return 0;
}

1001: A+B (II)

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 4111   Solved: 1354
[ Submit][ Status]

Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of real number a and b(0<=a,b<=1000000), separated by a space.

Output
For each case, output the answer in one line rounded to 4 digits after the decimal point.

For each case, output the answer in one line rounded to 4 digits after the decimal point.

Sample Input

1 5
10 20
0.1 1.5

Sample Output

6.0000
30.0000
1.6000

HINT

Source

[ Submit][ Status]


#include<stdio.h>
using namespace std;
int main(){
    double a,b;
    while(~scanf("%lf %lf",&a,&b))
    {
        printf("%.4f\n",a+b);
    }
    return 0;

}

1002: A+B (III)

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 3136  Solved: 1109
[ Submit][ Status]

Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a and b(1=< a,b <=1016), separated by a space. Input is followed by a single line with a = 0, b = 0, which should not be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 510 2010000000000000000 100000000000000000 0

Sample Output

63020000000000000000

HINT

Source

[ Submit][ Status]


#include<stdio.h>
#include<iostream>
using namespace std;
int main(){
    long long a,b;
    while(~scanf("%lld%lld",&a,&b))
    {

        if(a!=0&&b!=0)
            printf("%llu\n",a+b);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值