A1086. Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

这里写图片描述

Figure 1
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

Code:

#include "cstdio"
#include "stack"
#include "cstring"
#include "algorithm"
using namespace std;

const int maxn = 35;
int pre[maxn], in[maxn], post[maxn];
int n;  //结点个数

struct node
{
    int data;
    node* lchild;
    node* rchild;
};

node* create(int preL, int preR, int inL, int inR)
{
    if(preL > preR)
    {
        return NULL;
    }

    node* root = new node;
    root->data = pre[preL];

    int k;
    for(k = inL; k <= inR; k++)
    {
        if(in[k] == pre[preL])
            break;
    }
    int numLeft = k - inL;  //左子树结点个数

    root->lchild = create(preL + 1, preL + numLeft, inL, k - 1);

    root->rchild = create(preL + numLeft + 1, preR, k + 1, inR);

    return root;
}

int num = 0; //记录已输出的结点个数
void postOrder(node* root)  //后序递归遍历
{
    if(root == NULL)
    {
        return;
    }
    postOrder(root->lchild);
    postOrder(root->rchild);

    printf("%d",root->data);
    num++;
    if(num < n) printf(" ");
}

int main()
{
    scanf("%d",&n);
    char str[5];
    stack<int> st;
    int x,preIndex = 0, inIndex = 0;
    for(int i = 0; i < 2 * n; i++)
    {
        scanf("%s",str);
        if(strcmp(str, "Push") == 0)
        {
            scanf("%d",&x);
            pre[preIndex++] = x;   //令pre[preIndex]=x
            st.push(x);
        }
        else
        {
            in[inIndex++] = st.top();  //令in[inIndex]=st.top
            st.pop();
        }
    }
    node* root = create(0, n - 1, 0, n - 1);
    postOrder(root);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值