1sting(大数递归)

Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.

Output
The output contain n lines, each line output the number of result you can get .

Sample Input
3
1
11
11111

Sample Output
1
2
8

题意:两个1凑在一起可以合成2,问可以合成几种数字
比如111可以有21、12、111三种
大数的递归

代码(C)

#include<stdio.h>
#include<string.h>
int a[1010][1010];//因为是大数,一维数组并不能储存数字,所以用二维,后面用来分别储存大数的每个位数
int main()
{
    int q,m,n,t;
    int ans,r,s,i;
    r=0;
    memset(a,0,sizeof(a));
    a[1][1]=1;
    a[2][1]=2;
    for(i=1;i<=997;i++)//大数的加法
    {
        for(int j=1;j<=1010;j++)
        {
            s=a[i][j]+a[i+1][j]+r;
            a[i+2][j]=s%10;
            r=s/10;
        }
    }
    scanf("%d",&t);
    while(t--)
    {
        char str[201];
        scanf("%s",&str);
        n=strlen(str);
        if(n==1)  printf("1\n");
        else if(n==2)  printf("2\n");
        else 
        {

            for(i=1010;i>=1;i--) if(a[n][i])break; //当a[n][i]为0时跳出,此时的i即答案有几位数,进入下一步的输出
            for(;i>=1;i--)  
              printf("%d",a[n][i]);  
            printf("\n");  
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值