PAT A1107 Social Clusters (30分) (并查集)

PAT甲级:A1107 Social Clusters (30分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
  • 题意:给出n个人的爱好,人物和爱好编号都为1到N,有同样爱好的人视作在一个群组,要求找出,这群人中有几个共同兴趣小组,输出群组数并按降序输出各组人数。
  • 分析:需要用到并查集,同时,用hobby数组做哈希表标记谁有当前爱好,如果hobby是0则说明之前没记录过,需要记录一下,如果不为0,这找到其所在的群组,将当前的人合并到这个集合。之后遍历n个人,找到所有的群组并存到unordered_map中,再将结果转到vector中降序输出。
#include <bits/stdc++.h>
using namespace std;
const int N = 1010;
int father[N];
int findFather(int x) {
    return x == father[x] ? x : father[x] = findFather(father[x]);
}
void uni(int a, int b) {
    int faA = findFather(a);
    int faB = findFather(b);
    if (faA != faB) father[faA] = faB;
}
int main() {
    for (int i = 0; i < N; i++) father[i] = i;
    int n, k, h, hobby[N] = {0};
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        scanf("%d: ", &k);
        for (int j = 0; j < k; j++) {
            scanf("%d", &h);
            if (hobby[h] != 0) uni(i, findFather(hobby[h]));
            else hobby[h] = i;
        }
    }
    unordered_map<int, int> mp;
    vector<int> ans;
    for (int i = 1; i <= n; i++) mp[findFather(i)]++;
    for (auto it : mp) ans.push_back(it.second);
    printf("%d\n", ans.size());
    sort(ans.begin(), ans.end());
    for (int i = ans.size() - 1; i >= 0; i--) {
        printf("%d", ans[i]);
        if (i != 0) printf(" ");
    }
    return 0;
}
### 使用并查集算法解决社交网络中的共同爱好问题 为了处理社交网络中用户的兴趣爱好并将有相同兴趣爱好的用户组到不同的社交集群,可以采用并查集(Union-Find Set)数据结构。该方法能够高效地管理和查询不同元素之间的连通关系。 #### 并查集简介 并查集是一种树型的数据结构,用于处理一些不相交集合的合并及查询操作。对于给定的一系列元素,可以通过一系列的操作将其划为若干个互不相交的子集,并支持快速查找某个元素属于哪个子集以及将两个子集合并成一个新的子集的功能[^1]。 #### 解决方案设计 针对这个问题的具体实现方式如下: - **初始化**:创建一个大小为N+1的数组`parent[]`,其中索引代表用户编号,初始状态下每个节点都是自己的父节点。 - **读取输入**:按照题目描述的方式逐行读入每位用户的信息及其对应的兴趣标签列表。 - **构建映射表**:建立一张哈希表或者字典来记录每一个兴趣标签首次出现时对应的那个用户ID作为根节点;如果遇到已经存在于表格里的兴趣,则通过路径压缩技术把当前用户加入到已存在的那个群组里去。 - **执行合并操作**:遍历所有人的兴趣列表,在发现重复的兴趣项时就调用union函数连接这两个账号所属群体。 - **统计结果**:最后再扫描一遍所有人,利用find函数确定他们各自所在的最终社团归属情况,并输出各个独立社区内的成员名单。 以下是具体的Python代码实现: ```python def find(x, parent): if parent[x] != x: parent[x] = find(parent[parent[x]], parent) # 路径压缩 return parent[x] def union(x, y, parent): rootX = find(x, parent) rootY = find(y, parent) if rootX != rootY: parent[rootX] = rootY n = int(input()) interest_map = {} parent = list(range(n + 1)) for i in range(1, n + 1): _, *interests = input().split() for interest in interests: if interest not in interest_map: interest_map[interest] = i else: union(i, interest_map[interest], parent) clusters = {} for j in range(1, n + 1): root = find(j, parent) if root not in clusters: clusters[root] = [] clusters[root].append(str(j)) print(len(clusters)) for cluster in clusters.values(): print(' '.join(cluster), end=' ') ``` 此程序实现了基于并查集的社会团体划逻辑,有效地解决了寻找具有相似特征个体的问题[^2]。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值