A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 413509 Accepted Submission(s): 80134
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
Author
#include<stdio.h>
#include<string.h>
int main()
{
int N;
int count=1;
scanf("%d",&N);
while(N--)
{
char a[1000],b[1000],c[1001];
int i,p=0,n1,n2;
scanf("%s %s",a,b);
printf("Case %d:\n",count++);
printf("%s + %s = ",a,b);
n1=strlen(a)-1;//如输入12345,串长是5,但是最后一位5在数组里的下标是4
n2=strlen(b)-1;
for(i=0;n1>=0||n2>=0;i++,n1--,n2--)//注意出来的结果是倒序的
{
if(n1>=0&&n2>=0){c[i]=a[n1]+b[n2]-'0'+p;}//当两者位数相同
if(n1>=0&&n2<0){c[i]=a[n1]+p;}//位数不同时会出现
if(n1<0&&n2>=0){c[i]=b[n2]+p;}
p=0;
if(c[i]>'9'){c[i]-=10;p=1;}//进位
}
if(p==1)
printf("%d",p);//如果进位,先输入1
while(i--)//巧妙利用上面循环中的变量i 细微处见真功夫
printf("%c",c[i]);
if(N!=1)
printf("\n\n");//Output a blank line between two test cases.
else printf("\n");//特别注意 只有在两个输出间才需要多输一行,最后一个输出完时只需一个\n
}
return 0;
}