HDU-1002 A + B Problem II
Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 65536/32768K (Java/Other)
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1002
分析
题意:A+B大数问题,求A+B的值
思路:看数据就明白了,这是一个大数问题。大数的思想实际上就是将运算的过程实现出来。用两个字符串分别储存两个数,再转换成数组进行加法运算就可以了。大数的加法相对来说还是很容易理解的。代码很容易就可以看懂。
代码
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
char num1[1005],num2[1005];
int Bnum1[1005],Bnum2[1005];
int n;
cin>>n;
for (int i=0;i<n;i++)
{
memset(Bnum1,0,sizeof(Bnum1));
memset(Bnum2,0,sizeof(Bnum2));
cin>>num1>>num2;
int len1=strlen(num1);
int len2=strlen(num2);
for (int i=len1-1;i>=0;i--)
Bnum1[len1-1-i]=num1[i]-'0';
for (int i=len2-1;i>=0;i--)
Bnum2[len2-1-i]=num2[i]-'0';
int len=max(len1,len2);
int carry=0;
for (int i=0;i<len;i++)
{
Bnum2[i]+=Bnum1[i]+carry;
carry=Bnum2[i]/10;
if (Bnum2[i]>=10)
Bnum2[i]-=10;
}
Bnum2[len]=carry;
if (carry!=0)
len++;
cout<<"Case "<<i+1<<":"<<endl;
cout<<num1<<" + "<<num2<<" = ";
for (int i=len-1;i>=0;i--)
cout<<Bnum2[i];
cout<<endl;
if (i!=n-1)
cout<<endl;
}
return 0;
}