[PAT-甲级]1009.Product of Polynomials

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

解题思路:PAT1002. 考察点是两个多项式的加法计算,本题考察的是两个多项式的乘法计算。

  • 最高项是1000,所有两个多项式相乘得到的最高项是<=2000的。
  • 只需要输出非0项,即系数为0,不需要输出
  • 读入第2个多项式的时候,边读入边计算
代码如下:
#include<stdio.h>

// 定义结构体ploy数组保存第一组多项式的输入
struct Poly
{
	int exp;
	double cof;
}poly[1010];

// 保存运算的结果
double ans[2010];

int main()
{
	int n, m, count = 0;
	// 读入第一个多项式
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d %lf", &poly[i].exp, &poly[i].cof);
	
	// 读入第二个多项式
	scanf("%d", &m);
	for (int i = 0; i < m; i++)
	{
		int exp;
		double cof;

		// 边读入边计算,每读入项都需要跟第一个多项式中每一项相乘
		scanf("%d %lf", &exp, &cof);
		for (int j = 0; j < n; j++)
			ans[exp + poly[j].exp] += (cof*poly[j].cof);
	}

	// 统计非0项的个数
	for (int i = 0; i <= 2000; i++)
	{
		if (ans[i] != 0.0)
			count++;
	}

	// 从高到低打印结果
	printf("%d", count);
	for (int i = 2000; i >= 0; i--)
	{
		if (ans[i] != 0.0)
			printf(" %d %.1f", i, ans[i]);
	}
	
	return 0; 
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值